"Clear Downloads" button is grayed out if mixed finished and unfinished downloads in downloads window

RESOLVED WORKSFORME

Status

()

Toolkit
Downloads API
P4
normal
RESOLVED WORKSFORME
2 years ago
11 months ago

People

(Reporter: that-ben, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8785728 [details]
asdasdsd.png

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

1) Download a file and wait until the download is completed.

2) Download another file and WHILE it is still downloading, open the downloads window.




Actual results:

The CLEAR DOWNLOADS button is grayed out even tough there is at least 1 download completed.


Expected results:

The CLEAR DOWNLOADS button should be functional in this case, like it was in older versions of Firefox.
(Reporter)

Updated

2 years ago
Priority: -- → P4
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101

I have tested this issue on Windows 10 x64 with the latest Firefox release (48.0.2) and the latest Nightly (51.0a1-20160812030200) and could not reproduce it.
After finishing downloading a file and starting to download a new one, while it is still downloading when opening the downloads window and opening the context menu by right clicking in the downloads window, the "Clear Downloads" option is available and functional.

Can you please retest this using the latest Firefox release and  the latest Nightly build (https://nightly.mozilla.org/) and report back the results? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
(Reporter)

Comment 2

2 years ago
Could not reproduce the bug this morning.  Maybe it got fixed in 48.0.2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

2 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 3

2 years ago
Well, I spoke too soon.  It just happened again on 48.0.2

I noticed when this happens, the unfinished download is in the first slot and finished downloads are in the second, third, etc slots... See the original screenshot and this attached screenshot, both occurance of the bug is when the unfinished download is in the first slot: http://oi66.tinypic.com/5vadlx.jpg
(Reporter)

Comment 4

2 years ago
And this morning it happened again, twice, here's what I had in the downloads window for one of the 2 times: http://oi63.tinypic.com/s5jv5i.jpg

When this happened, I could even close the window and re-open it and it stayed grayed out until the download was finished.
I am assigning a component to this issue in order to involve the development team and get an opinion on this.
Component: Untriaged → Download Manager
Product: Firefox → Toolkit
(Reporter)

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago11 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.