If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

No Warning When "File Save As" Fails to Save Anything at All

RESOLVED FIXED in mozilla1.2alpha

Status

Core Graveyard
File Handling
--
critical
RESOLVED FIXED
16 years ago
a year ago

People

(Reporter: Felix Miata, Assigned: Bill Law)

Tracking

({dataloss})

Trunk
mozilla1.2alpha
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
2002030816 OS/2

This surfaced as a result of bug 129696 and bug 70045.

Attempting to "file save as" with Mozilla apparently means save a bunch of
files, the selected URL, along with all page elements, with no control over the
names of the elements, rather than literally saving the selected URL. When
making an attempt to save on a legacy filesystem with the 8.3 filename
restriction, longnames cannot be written, so the file write operation fails. Not
only does it fail, it fails to save any portion of the selected page or its
elements, even though some portion of the elements or the page itself conforms
to 8.3 naming. Then to top it off, Mozilla makes no warning about the failure.

Comment 1

16 years ago
This is easily recreatable on Windows as well.

Create a file called www.yahoo.com_files

Go to www.yahoo.com

Select Save Page.

You get no error messages and nothing is saved.

We are NOT going to fix ANY of the 8.3 issues.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: OS/2 → All
Hardware: PC → All

Comment 2

16 years ago
file handling
Assignee: dougt → law
Component: Networking: File → File Handling
QA Contact: benc → sairuh

Updated

16 years ago
Keywords: dataloss, mozilla1.0, nsbeta1

Comment 3

16 years ago
cc ben

Comment 4

16 years ago
nsbeta1- per Nav triage team, ->1.2
Keywords: nsbeta1 → nsbeta1-
Target Milestone: --- → mozilla1.2alpha
QA Contact: sairuh → petersen

Comment 5

15 years ago
*** Bug 182973 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: normal → critical

Comment 7

14 years ago
I am also seeing this on Win2K on Mozilla/5.0 (Windows; U; Windows NT 5.0;
en-US; rv:1.7b) Gecko/20040316

I didn't notice this Lucky I have firefox.

However, I was able to fix this by shutting down mozilla completely and deleting
the /components/comreg.dat file... After restarting mozilla everything was peachy.

Comment 8

13 years ago
I am experiencing this bug too.  I am using Mozilla 1.8a3 Mozilla/5.0 (Windows;
U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040817 on Windows XP home.  In my
case, when I try to use "save as" on an image, file, page, or link, I get the
dialog where I choose a filename and location.  Download manager fails to open,
nothing is saved, and I receive no warning at all.

The fix proposed by jlee105@columbus.rr.com whereby one deletes the
/components/compreg.dat file works for me.  Note that the correct name for this
file is compreg.dat, not comreg.dat.  I've experienced this bug twice and fixed
once by completely uninstalling and reinstalling Mozilla and the second time by
deleting the /components/compreg.dat file.

Interestingly, I am playing with the new Sunbird calendar and had to delete the
same file to get my calendar to work - see
http://bugzilla.mozilla.org/attachment.cgi?id=122860&action=view

Comment 9

13 years ago
This bug (as per comment #2) should be fixed by checkin to bug 281343.

Comment 10

13 years ago
Sorry, I meant comment #1.

Comment 11

9 years ago
(In reply to comment #9)
> This bug (as per comment #2) should be fixed by checkin to bug 281343.

So is this fixed now?

Comment 12

9 years ago
It is fixed in the case where there is an existing file (e.g. www.yahoo.com_files) and you attempt to save a page with the same name without _files (eg. www.yahoo.com).

As for the original comment, I'm not sure as it's a bit vague (no reproducible steps or test case).
(Reporter)

Comment 13

9 years ago
comment 1 has the steps to reproduce

Comment 14

9 years ago
(In reply to comment #13)
> comment 1 has the steps to reproduce

If that's the case then this bug is fixed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.