image/svg+xml tries to download the image instead of displaying it

RESOLVED DUPLICATE of bug 160882

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 160882
16 years ago
4 years ago

People

(Reporter: Georg Maaß, Assigned: Alex Fritze)

Tracking

({pp})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
I think any mime type containing "xml" in the second part of the mime type like
application/xhtml+xml or text/xml or image/svg+xml or x-mystuff/x-myphantasy+xml
should enable SVG detection and SVG rendering. But at least on W2K a mimetype
like image/svg+xml results in a download instead of displaying the image. That's
not nice.

Andrew Hurt wrotes in news:netscape.public.mozilla.svg

> Georg,
>
> I have registered image/svg+xml here in Debian, and associated it with
> Mozilla 0.9.8 (and bluefish, a mark-up editor).  I use Nautilus (kinda like
> Explorer/File Manager) which, itself, shows the contents of .svg files in
> their icons.  When I click on a .svg it opens into an unplugged Mozilla just
> fine (and if I access a straight .svg from a server, it also loads fine into
> Mozilla).  I should add that a .svg with a x=%/y=% aspect does not display
> for me in Mozilla.
>
> If I try to do these things in Win2K, I get the 'choose application:' dialog.
> I have tried to register the image/svg+xml with Mozilla 0.9.8, but still get
> the chooser.
>
> My only thought is that there is some underlying tie between the Internet
> Explorer core and anything in the xml family.  All pure speculation, as I am
> not savoring the possible breakage of xml functions by tying these to Mozilla
> (if at all possible).
>
> As for javascript, I know very little, but have been able to get read-only 
> access to <svg> content that is expressed, inline, within an *.xhtml/*.xht
>
> ah


If IE is nerving, then a gun down IE workaround must be implemented, to make
Mozilla handle the images correctly.
So it works when you open it from within mozilla, but not from explorer?
(Reporter)

Comment 2

16 years ago
I never tried to view SVG with IE. I tried it with NN4 on my Mac using the
plugin, which displayed the SVG image, and I tried it on W2K with Mozilla 0.9.7
MathML+SVG which wants to download the SVG. If I change the extension from .svg
to .xml, then ther Server changes the Content-Type header from image/svg+xml to
text/xml. In this case Mozilla displays the SVG image, where Netscape 4 tries to
download, becaus this is an invalid mime type for SVG images.
Is this still a problem?  Could someone list clear and concise steps to reproduce?

Marking pp as it sounds like this is Windows-only.
Keywords: pp

Comment 4

15 years ago
Related or dup? Bug 160882 MIME type image/svg+xml should be supported

To reproduce this bug, load http://www.mozilla.org/projects/svg/lion.svg
In the absence of a clarification from the reporter, duping.

*** This bug has been marked as a duplicate of 160882 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.