Identity block icon becomes black when animating with camera/mic

VERIFIED FIXED in Firefox 51

Status

()

defect
P1
normal
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: agrigas, Assigned: dao)

Tracking

({regression})

Trunk
Firefox 51
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, firefox50 unaffected, firefox51+ verified)

Details

(Whiteboard: [fxprivacy] )

Attachments

(2 attachments)

The "i" icon currently shows as filled in with black and it should be the default state of the "i" icon with the gray outline and white fill.
Whiteboard: [fxprivacy] → [fxprivacy] [triage]
It would be really helpful to have softvision do some isolation for us.
Flags: needinfo?(adrian.florinescu)
Priority: -- → P1
Whiteboard: [fxprivacy] [triage] → [fxprivacy]
The fill doesn't seem to be an issue, the problem is rather that the (i) icon is black instead of grey, no matter the state. This could be a regression from bug 1206233 but I'm very sure we would've noticed that. I think this was caused by some underlying platform changes after the patches for bug 1206233 landed.

It would be very interesting to find the offending patch.
Blocks: 1206233
Summary: Identity block camera/mic icon animation should show "i" icon as outline not filled → Identity block icon becomes black when animating with camera/mic
I attached a GIF showing the problem.
[Tracking Requested - why for this release]: This is a central piece of UI that looks really ugly when not fixed. We don't think bug 1206233 has caused the regression but it added the UI parts.
Using the mozregression tool narrowed the regression window to:
Last good revision: 2069e3662c134694bbab8db555b633faaddf3549
First bad revision: 6af49d08884d76de44efd9387bbe340921652364
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=2069e3662c134694bbab8db555b633faaddf3549&tochange=6af49d08884d76de44efd9387bbe340921652364
Flags: needinfo?(adrian.florinescu)
I'm guessing bug 1022601 is the culprit here, but I'm sure Dão will let me know if that is wrong.
Blocks: 1022601
No longer blocks: 1206233
Flags: needinfo?(dao+bmo)
Posted patch patchSplinter Review
I'm actually not sure which part of my patch caused the bug, but this seems to fix it.
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Flags: needinfo?(dao+bmo)
Attachment #8788349 - Flags: review?(jhofmann)
Comment on attachment 8788349 [details] [diff] [review]
patch

Review of attachment 8788349 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good! Not really sure what fixed it in the end, either. ¯\_(ツ)_/¯

We should watch the mozscreenshots for this patch to catch platform-specific regressions.
Attachment #8788349 - Flags: review?(jhofmann) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/f5ba84cadbc9
Move icon transparency into identity-icon.svg and tracking-protection-16.svg and remove !important from .plugin-icon.plugin-blocked opacity. r=johannh
Tracking 51+ for all the reasons in Comment 4.
Iteration: --- → 51.3 - Sep 12
https://hg.mozilla.org/mozilla-central/rev/f5ba84cadbc9
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
I have reproduced this bug with Firefox nightly 51.0a1 (2016-08-30) on Windows 10, 64 Bit.

The Bug's fix is now verified on latest nightly 51.0a1 (2016-09-07).


Build ID 	20160907030427
User Agent 	 	Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160907]
Thanks!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.