Devtools inspector not loading until page resources finish loading

RESOLVED DUPLICATE of bug 1151909

Status

()

Firefox
Developer Tools: Inspector
RESOLVED DUPLICATE of bug 1151909
2 years ago
2 years ago

People

(Reporter: andreio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User Story

http://recordit.co/mHHiHTx8T5 correct gif of recording
(Reporter)

Description

2 years ago
This reproduces in Dev edition an latest stable.

STR:
Have the inspector tools open
Navigate to a page with resources that are slow to load
Behavior: Until resources finish loading the inspector does not load

I don't know what the expected behavior should be but waiting on an image to load should not influence my ability to inspect a page. I have to either wait or stop page load.

Here is a recording of the behavior: http://g.recordit.co/mHHiHTx8T5.gif
Until the image has finished loading the inspector does not fire. Resources loaded are from lorempixel.com
(Reporter)

Updated

2 years ago
User Story: (updated)
(Reporter)

Updated

2 years ago
Summary: Devtools inspector not working until resources finish loading → Devtools inspector not loading until page resources finish loading
We should be loading up the markup view on DOMContentLoaded instead but we are currently using a web progress listener - duping this to Bug 1151909
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1151909
Component: Developer Tools → Developer Tools: Inspector
You need to log in before you can comment on or make changes to this bug.