ImportError: No module named twisted.internet | ERROR runtests.py | websocket/process bridge failed to launch. Are all the dependencies installed? in Android media tests

RESOLVED FIXED in mozilla51

Status

RESOLVED FIXED
2 years ago
9 months ago

People

(Reporter: aryx, Assigned: maja_zf)

Tracking

({regression})

unspecified
mozilla51
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

This seems to be a regression from bug 1284874: https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=000140429082af3830a2f7a61208132a8be43ca6&selectedJob=2565412

Since that job, the logs of the media tests on Android 4.3 (at least) contain (even for successful runs):

08:44:12     INFO -  MochitestServer : launching [u'/builds/slave/test/build/hostutils/host-utils-50.0a1.en-US.linux-x86_64/xpcshell', '-g', '/builds/slave/test/build/hostutils/host-utils-50.0a1.en-US.linux-x86_64', '-v', '170', '-f', '/builds/slave/test/build/hostutils/host-utils-50.0a1.en-US.linux-x86_64/components/httpd.js', '-e', "const _PROFILE_PATH = '/tmp/tmpu98FtM.mozrunner'; const _SERVER_PORT = '8854'; const _SERVER_ADDR = '10.0.2.2'; const _TEST_PREFIX = undefined; const _DISPLAY_RESULTS = false;", '-f', '/builds/slave/test/build/tests/mochitest/server.js']
08:44:12     INFO -  runtests.py | Server pid: 2039
08:44:12     INFO -  runtests.py | Websocket server pid: 2042
08:44:12     INFO -  runtests.py | websocket/process bridge pid: 2046
08:44:12     INFO -  Traceback (most recent call last):
08:44:12     INFO -    File "websocketprocessbridge/websocketprocessbridge.py", line 6, in <module>
08:44:12     INFO -      from twisted.internet import protocol, reactor
08:44:12     INFO -  ImportError: No module named twisted.internet
08:44:12     INFO -  0 ERROR runtests.py | websocket/process bridge failed to launch. Are all the dependencies installed?
Maja, can you take a look at this, please?
Component: General Automation → Task Configuration
Flags: needinfo?(mjzffr)
Product: Release Engineering → Taskcluster
Comment hidden (mozreview-request)
(Assignee)

Comment 4

2 years ago
Or more accurately, this was due to an over-indented line.

Comment 5

2 years ago
mozreview-review
Comment on attachment 8786866 [details]
Bug 1299242 - Fix regression with installing requirements in AndroidEmulatorTest;

https://reviewboard.mozilla.org/r/75748/#review73640
Attachment #8786866 - Flags: review?(gbrown) → review+

Comment 6

2 years ago
Pushed by mjzffr@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/21f26d14f34b
Fix regression with installing requirements in AndroidEmulatorTest; r=gbrown

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/21f26d14f34b
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51

Updated

9 months ago
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.