Intermittent dom/media/tests/mochitest/test_peerConnection_addAudioTrackToExistingVideoStream.html | application crashed [@ TelemetryHistogram::AccumulateChild] | after Assertion failure: isValid, at TelemetryHistogram.cpp:2157

RESOLVED DUPLICATE of bug 1304009

Status

()

Toolkit
Telemetry
P3
normal
RESOLVED DUPLICATE of bug 1304009
a year ago
a year ago

People

(Reporter: Treeherder Bug Filer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
treeherder
Filed by: wkocher [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=34969051&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/ACxJpxl6RAafFmGyoQeP4w/runs/0/artifacts/public%2Flogs%2Flive_backing.log
Could this be related to bug 1218576 as well?
Flags: needinfo?(chutten)

Comment 2

a year ago
This is definitely in code added by bug 1218576 (which has been backed out. How in the world did we get an intermittent report in the few minutes the code was in the tree? Efficient, but kinda odd :S)

This is one of those tricky tests that ./mach test doesn't know how to run, isn't it. Are there instructions on how to run these locally?

(( Also, isValid can only fail the assert if the IPC message coming across is sending us an invalid telemetry ID... which ought to be impossible in normal operation ))
Flags: needinfo?(chutten)
(In reply to Chris H-C :chutten from comment #2)
> This is definitely in code added by bug 1218576 (which has been backed out.
> How in the world did we get an intermittent report in the few minutes the
> code was in the tree? Efficient, but kinda odd :S)

Yeah :-\ Maybe somebody pushed right after you... bad luck :-(

> This is one of those tricky tests that ./mach test doesn't know how to run,
> isn't it. Are there instructions on how to run these locally?

I can seem to run it using:

./mach mochitest dom/media/tests/mochitest/test_peerConnection_addAudioTrackToExistingVideoStream.html

> (( Also, isValid can only fail the assert if the IPC message coming across
> is sending us an invalid telemetry ID... which ought to be impossible in
> normal operation ))

Yeah :-/ This sounds... weird.

Comment 4

a year ago
Yup, that did it for me, too... but the test never completes (one of the processes doesn't terminate). Maybe yet another Windows problem?

We specifically put in the if (!isValid) return; in so that the code _wouldn't_ crash (see bug 1218576 comment 103).

Adding this to the xpcshell netwerk IPC failures causing the backouts for bug 1218576 and there must be something wrong in IPC land... but I don't know _what_.
Blocks: 1218576

Comment 5

a year ago
It has to do with me not being safe about what threads I access timers. With a hackfix, mochitest comes up "clean" on try: https://treeherder.mozilla.org/#/jobs?repo=try&revision=bc52642380e0&selectedJob=26695371

Still thinking about the best way to architect a proper fix.

Comment 6

a year ago
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
No point in leaving this one open since work is happening in bug 1304009 now.
No longer blocks: 1218576
Status: NEW → RESOLVED
Last Resolved: a year ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1304009
You need to log in before you can comment on or make changes to this bug.