SVG Not rendered correctly.

VERIFIED DUPLICATE of bug 1297201

Status

()

Core
Graphics
VERIFIED DUPLICATE of bug 1297201
a year ago
a year ago

People

(Reporter: lucas, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8786572 [details]
Pie Chart Results.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160817112116

Steps to reproduce:

I have an inline SVG I use as a Pie chart. I noticed this week that it isn't rendering properly in Firefox on OS. Not positive what version of Firefox it started failing in.

You can see the pie chart I'm using in the JS Fiddle linked to below. 

https://jsfiddle.net/wofwv6pc/1/

Below is the information from my "Troubleshooting Information" screen. I tried starting Firefox in safe mode and I got the same results.

Application Basics
------------------

Name: Firefox
Version: 48.0.1
Build ID: 20160817112116
Update Channel: release
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:48.0) Gecko/20100101 Firefox/48.0
OS: Darwin 15.6.0 x86-64
Multiprocess Windows: 0/1 (Disabled)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: 1Password
Version: 4.5.9
Enabled: true
ID: onepassword4@agilebits.com

Name: DuckDuckGo Plus
Version: 0.5.7
Enabled: true
ID: jid1-ZAdIEUB7XOzOJw@jetpack

Name: Firefox Hello
Version: 1.4.4
Enabled: true
ID: loop@mozilla.org

Name: Ghostery
Version: 6.3.2
Enabled: true
ID: firefox@ghostery.com

Name: Multi-process staged rollout
Version: 1.1
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.4
Enabled: true
ID: firefox@getpocket.com

Name: Tab Groups
Version: 2.0.1
Enabled: true
ID: tabgroups@quicksaver

Name: The Addon Bar (restored)
Version: 3.2.9-compat-fixed-4
Enabled: true
ID: the-addon-bar@GeekInTraining-GiT

Name: The easiest Xdebug
Version: 2.1.1-signed.1-signed
Enabled: true
ID: jid1-fQpPMP6uBdJNCg@jetpack

Name: uBlock Origin
Version: 1.9.4
Enabled: true
ID: uBlock0@raymondhill.net

Graphics
--------

Features
Compositing: OpenGL
Asynchronous Pan/Zoom: none
WebGL Renderer: NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine
Hardware H264 Decoding: Yes
GPU #1
Active: Yes
Vendor ID: 0x8086
Device ID: 0x0166

Diagnostics
AzureCanvasAccelerated: 1
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: none


Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.sessionstore.upgradeBackup.latestBuildID: 20160817112116
browser.startup.homepage_override.buildID: 20160817112116
browser.startup.homepage_override.mstone: 48.0.1
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.reset-permissions: true
dom.mozApps.used: true
extensions.lastAppVersion: 48.0.1
font.internaluseonly.changed: false
gfx.blacklist.direct2d: 3
gfx.blacklist.direct2d.failureid: FEATURE_FAILURE_DL_BLACKLIST_g984
media.benchmark.vp9.fps: 209
media.benchmark.vp9.versioncheck: 1
media.gmp-gmpopenh264.abi: x86_64-gcc3-u-i386-x86_64
media.gmp-gmpopenh264.lastUpdate: 1471567800
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20160817112116
media.gmp-manager.lastCheck: 1472535568
media.gmp-widevinecdm.abi: x86_64-gcc3-u-i386-x86_64
media.gmp-widevinecdm.lastUpdate: 1465671030
media.gmp-widevinecdm.version: 1.4.8.866
media.gmp.storage.version.observed: 1
media.webrtc.debug.aec_log_dir: /Users/lucasbonner/Library/Caches/TemporaryItems
media.webrtc.debug.log_file: /Users/lucasbonner/Library/Caches/TemporaryItems/WebRTC.log
network.cookie.cookieBehavior: 3
network.cookie.prefsMigrated: true
network.dns.disablePrefetch: true
network.http.speculative-parallel-limit: 0
network.predictor.cleaned-up: true
network.prefetch-next: false
places.database.lastMaintenance: 1471826071
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
print.print_bgcolor: false
print.print_bgimages: false
print.print_duplex: -437918235
print.print_evenpages: true
print.print_in_color: true
print.print_margin_bottom: 0.5
print.print_margin_left: 0.5
print.print_margin_right: 0.5
print.print_margin_top: 0.5
print.print_oddpages: true
print.print_orientation: 0
print.print_page_delay: 50
print.print_paper_data: 0
print.print_paper_height: 11.00
print.print_paper_name:
print.print_paper_size_unit: 0
print.print_paper_width: 8.50
print.print_resolution: -437918235
print.print_reversed: false
print.print_scaling: 1.00
print.print_shrink_to_fit: true
print.print_to_file: false
print.print_unwriteable_margin_bottom: 16
print.print_unwriteable_margin_left: 16
print.print_unwriteable_margin_right: 16
print.print_unwriteable_margin_top: 16
privacy.cpd.cookies: false
privacy.cpd.downloads: false
privacy.cpd.formdata: false
privacy.cpd.history: false
privacy.cpd.sessions: false
privacy.sanitize.migrateClearSavedPwdsOnExit: true
privacy.sanitize.timeSpan: 0
services.sync.declinedEngines:
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1470888332

Important Locked Preferences
----------------------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.12
Version in use: 4.12

NSS
Expected minimum version: 3.24 Basic ECC
Version in use: 3.24 Basic ECC

NSSSMIME
Expected minimum version: 3.24 Basic ECC
Version in use: 3.24 Basic ECC

NSSSSL
Expected minimum version: 3.24 Basic ECC
Version in use: 3.24 Basic ECC

NSSUTIL
Expected minimum version: 3.24
Version in use: 3.24

Experimental Features
---------------------



Actual results:

 I'm now just seeing a crescent moon oriented like a bowl instead of seeing a circle/pie chart.


Expected results:

I should be seeing a circle/pie chart.
I confirmed the issue on Firefox 48.0.2, and also confirmed the fix on Nightly.
Here's fix range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=3e859924d2f5a2b51cf11d07201a08b7cc520feb&tochange=4e8a67e61102cb05b004fb4b9557ebb41812b9d0

Looks like it's already fixed by bug 1289829.

Can you also check that it's fixed on nightly?
Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics
Ever confirmed: true
Product: Firefox → Core
See Also: → bug 1289829
(Reporter)

Comment 2

a year ago
I will look at this tonight.
This was actually fixed in bug 1297201 in nightly/51. I confirmed that the bug reproduced with my fix in that bug backed out and was resolved with my fix put back in. I'll see if I can get this uplifted to 49 and 50. Marking this as a dup since I'm fairly certain on this one.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(lucas)
Resolution: --- → DUPLICATE
Duplicate of bug: 1297201
(Reporter)

Comment 4

a year ago
I can also confirm that my issue is fixed in Firefox Nightly.
You need to log in before you can comment on or make changes to this bug.