inspector/rule.js uses xul

RESOLVED DUPLICATE of bug 1265796

Status

()

Firefox
Developer Tools: Framework
RESOLVED DUPLICATE of bug 1265796
a year ago
a year ago

People

(Reporter: gasolin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
The rule.js uses some xul; and this component is loaded by the inspector.

In particular editor.js references `Services.appShell.hiddenDOMWindow.document` which is not shimed

https://dxr.mozilla.org/mozilla-central/source/devtools/client/inspector/rules/rules.js#95

and it require("sdk/frame/utils") , which should be replaced as well.
Blocks: 1263741
Flags: qe-verify-
Priority: -- → P2
Whiteboard: [reserve-html]

Comment 1

a year ago
The rule.js use is being fixed in bug 1265796.
Blocks: 1263750
No longer blocks: 1263741
Whiteboard: [reserve-html] → [devtools-html]
No longer blocks: 1263750
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: qe-verify-
Priority: P2 → --
Resolution: --- → DUPLICATE
Whiteboard: [devtools-html]
Duplicate of bug: 1265796
You need to log in before you can comment on or make changes to this bug.