Blank calendar section in MS Outlook webmail (OWA) after Firefox 48

NEW
Unassigned

Status

()

Core
Layout: Tables
a year ago
a year ago

People

(Reporter: shigman1, Unassigned, NeedInfo)

Tracking

({site-compat})

48 Branch
site-compat
Points:
---

Firefox Tracking Flags

(platform-rel -, firefox48 affected)

Details

(Whiteboard: [platform-rel-Microsoft][platform-rel-Outlook])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

Load Outlook web app.  App logs in correctly.


Actual results:

Email works correctly.  Calendar loads but no data.  Loads correctly on 47.0.1 on laptop.  Not a server issue.  Tried in safe-mode but no data


Expected results:

Calendar data populates.

Comment 1

a year ago
Same problem for me. Tested with the following and all fails to show any data in the calendar.

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160901030202

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160811171047
Tested on Windows 7 x64 with FF 48.0.2, FF Nightly 51.0a1 and I can't reproduce it. Tested with new profile and no add-ons. Please attach a print screen of the issue.

Please create a new profile, you have the steps here:https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

Also try in safe mode.

Updated

a year ago
Flags: needinfo?(shigman1)

Comment 3

a year ago
we had a couple of similar reports from users on sumo after the 48.0 update (so confirming based on that): https://support.mozilla.org/en-US/questions/firefox?tagged=bug1299444&show=all

chrome had a similar bug once and they had determined it was an issue with exposing Array.prototype.values - https://bugs.chromium.org/p/chromium/issues/detail?id=409858#c80
Status: UNCONFIRMED → NEW
status-firefox48: --- → affected
Ever confirmed: true
Flags: needinfo?(jorendorff)
Keywords: site-compat
Summary: Version48.X.X appears to interfere with MS Outlook webmail → Blank calendar section in MS Outlook webmail (OWA) after Firefox 48

Updated

a year ago
Component: Untriaged → Layout: Tables
Product: Firefox → Core

Updated

a year ago
See Also: → bug 1299593
Most likely the same problem as bug 1299593. If anyone in this bug would like to help confirm that we have the right fix for it, you can:

*   Install the mozregression command-line tool:
    http://mozilla.github.io/mozregression/install.html

*   Run this command to download a patched browser:
    mozregression --launch 00eff691634e --repo try

*   Try OWA with that browser and see if it works,
    then let us know what you find. (We expect it to work.)
Flags: needinfo?(jorendorff)

Comment 5

a year ago
I am affected by the bug (FF 48, Linux).
Testing with the mozregression build works for me.

Would be nice if this fix could make it into 49 or at least 50. It's quite annoying for us people who have to use Outlook ...

Comment 6

a year ago
JFYI: Works now in Firefox 50.0b4 (Linux).
Thanks!
platform-rel: --- → ?
Whiteboard: [platform-rel-Microsoft][platform-rel-Outlook]
platform-rel: ? → -
 shigman1 has this problem been resolved for you as well?

Comment 8

a year ago
For me, on 50.1.0 it doesn't. 
It used to show the other Outlook apps lower left, almost like in the 'real thing', now there is only a gray button, for mail.
You need to log in before you can comment on or make changes to this bug.