Right click Back/Forward button stops working

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: alice0775, Assigned: jkt)

Tracking

({regression})

51 Branch
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox50 unaffected, firefox51- verified)

Details

[Tracking Requested - why for this release]:

Build Identifier:
https://hg.mozilla.org/mozilla-central/rev/506facea63169a29e04eb140663da1730052db64
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0 ID:20160831030224


Steps To Reproduce:
1. Navigate several webpage in a tab
2. Right Click Back/Forward button

Actual Results:
Tab history menu does not pop up

Expected Results:
Tab history menu should pop up


Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=9a737024c5cc7632fa66a559ba9a4ae09a1a9451&tochange=08e4eadbb77d5789e41559ced20dc3fef8b93002

Regressed by: Bug 1272256
Flags: needinfo?(jkt)
Please include a test with this patch to make sure that this doesn't regress again.
Tracking 51+ for this regression.
Assignee: nobody → jkt
Flags: needinfo?(jkt)
Unable to replicate in Ubuntu, will try Windows as suggested.
(In reply to Jonathan Kingston [:jkt] from comment #3)
> Unable to replicate in Ubuntu, will try Windows as suggested.

I've managed to reproduce it in the latest m-c build but only on Windows platforms. With prior builds before this bug landed, users could right click on the back/forwards buttons and receive a context menu with a list of the history. With the latest m-c build, you have to quickly double click twice to get the same context menu. Examples:

* right click on the forward/back button
* wait a few ms and right click on it again and you'll get the context menu
** if you don't do the second right click a few ms after the first right click, it will seem like it's not working

Unfortunately, there's no errors or indicators of something going wrong under the browser console or the terminal when running m-c in debug.

Let me know if you need any help Jonathan :)
Fixed by backout.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Backout by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1d96c286f93e
Backed out changeset 08e4eadbb77d for causing bug 1299667
Un-track for 51 because it's fixed by backout bug 1272256.
Flags: qe-verify+
This issue is VERIFIED FIXED in Firefox Beta 51.0b9 and Firefox Nightly 53.0a1 (id: 20161219030207) on a Windows 10 x64 machine.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.