Closed Bug 1299738 Opened 4 years ago Closed 3 years ago

SourceSurfaceIncompatible crash in mozilla::gfx::GetBitmapForSurface

Categories

(Core :: Graphics, defect, critical)

51 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
firefox51 --- fixed

People

(Reporter: jchen, Assigned: lsalzman)

References

Details

(Keywords: crash, Whiteboard: [gfx-noted])

Crash Data

Attachments

(1 file)

This bug was filed from the Socorro interface and is 
report bp-7f0c305d-fc17-420f-ae1f-b03732160901.
=============================================================

Low volume crash at [1], SourceSurfaceIncompatible: "Non-Skia SourceSurfaces need to be DataSourceSurfaces". Crashes seem to have started with the 8-27 nightly (with regression range [2]), and there are consistently a few crashes per nightly.

[1] https://hg.mozilla.org/mozilla-unified/annotate/1a5b53a831e5/gfx/2d/DrawTargetSkia.cpp#l215

[2] https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=a551f534773cf2d6933f78ce7d82a7a33a99643e&tochange=c724ae8bb7b867b6bc65efa1049c0322457ff4b0
Blocks: skia-windows
Whiteboard: [gfx-noted]
Version: unspecified → 51 Branch
We have stale SourceSurfaceD2D1s lying around temporarily during a device reset till the browser notices to clean them up.

These will fail to map/convert to data surfaces. Normally this was not a problem in DrawTargetD2D1 or DrawTargetCairo since we would not crash, but only just bail out or at worst warn.

So, we're a little overzealous in always crashing in this case in Skia. So let's just warn here to be consistent.

Also clean up some old cruft that is unnecessary in DrawTargetSkia checking SourceSurface types.
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Attachment #8787303 - Flags: review?(mchang)
Attachment #8787303 - Flags: review?(mchang) → review+
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/657ba2f2611c
warn instead of crash if DrawTargetSkia's GetBitmapForSurface fails. r=mchang
https://hg.mozilla.org/mozilla-central/rev/657ba2f2611c
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Depends on: 1301920
You need to log in before you can comment on or make changes to this bug.