Closed Bug 1299754 Opened 3 years ago Closed 3 years ago

CSS filter broken on some web pages

Categories

(Core :: Web Painting, defect)

39 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1258421
Tracking Status
firefox48 --- wontfix
firefox49 --- wontfix
firefox-esr45 --- wontfix
firefox50 --- fix-optional
firefox51 --- fix-optional

People

(Reporter: mrovi9000, Unassigned)

References

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36

Steps to reproduce:

1. Open https://www.facebook.com/
2. Open the dev tools (Ctrl+Shift+I)
3. Click on the html element
4. In the CSS rules tab on the right, add a filter:

element {
    filter: brightness(80%);
}


Actual results:

The entire page turns blank.


Expected results:

The brightness should have been reduced properly.

Similar results occur with other filters (contrast, invert).

I am developing an accessibility extension that uses filters to reduce brightness. It would be great if filters worked consistently on all websites. Currently they only work on some pages, but not others.

Running Firefox 48.0.2 under Ubuntu 14.04 on an i7-3770S using its integrated graphics.
Attached image no-filter.png
Attached image filter.png
The problem remains on Firefox 51.0a1
I think a style sheet affect inline filters. Could you check below after your STR?

- Open Stylesheet Editor (Shift+F7)
- Disable each style sheet individually
- You can find a style sheet that affect inline filters
Good idea. The style that causes the problem is:

i.img u{left:-999999px;position:absolute}

Apparently it occurs only for very large absolute values of left.
Attached file testcase.htm
Microsoft Edge: Good
Firefox 48,49,50,51: NG
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: Untriaged → Layout: View Rendering
Product: Firefox → Core
Related (possible duplicate): bug 1299754
Component: Layout: View Rendering → Layout
See Also: → 1258421
Component: Layout → Layout: View Rendering
It pretty much looks like a dupe of bug 1258421.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1258421
Setting the status flags to drop this duplicate from triage and track in but 1258421 instead.
Component: Layout: View Rendering → Layout: Web Painting
You need to log in before you can comment on or make changes to this bug.