Crash on the profiler's SamplerThread in SharedScriptData::code() | ... | js::ProfileEntry::pc const volatile

RESOLVED FIXED in Firefox 51

Status

()

Core
JavaScript: GC
--
critical
RESOLVED FIXED
a year ago
a year ago

People

(Reporter: mstange, Assigned: jonco)

Tracking

({crash})

Trunk
mozilla51
All
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(firefox51 fixed)

Details

(crash signature)

(Reporter)

Description

a year ago
This bug was filed from the Socorro interface and is 
report bp-6ff11799-aeb6-4d3b-a919-84e9a2160901.
=============================================================

I just experienced a crash during startup in the sampler thread. I have the Gecko profiler addon installed.

This crash seems to be new 

https://crash-stats.mozilla.com/signature/?product=Firefox&signature=js%3A%3AProfileEntry%3A%3Apc%20const%20volatile&_columns=date&_columns=product&_columns=version&_columns=build_id&_columns=platform&_columns=reason&_columns=address&_sort=-date&page=1#reports
(Reporter)

Comment 1

a year ago
This crash seems to be new since August 27th.
Summary: Crash in SharedScriptData js::ProfileEntry::pc const volatile → Crash on the profiler's SamplerThread in SharedScriptData::code() | ... | js::ProfileEntry::pc const volatile
Probably a dupe of bug 1298639.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1298639
Fixed by bug 1298639.
Assignee: nobody → jcoppeard
status-firefox51: affected → fixed
Depends on: 1298639
Resolution: DUPLICATE → FIXED
Target Milestone: --- → mozilla51
Duplicate of this bug: 1300471
You need to log in before you can comment on or make changes to this bug.