Fennec will often show a flash of the contents of the previous tab when switching tabs

RESOLVED FIXED in Firefox 51

Status

()

Firefox for Android
General
P2
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: rbarker, Assigned: rbarker)

Tracking

({regression})

51 Branch
Firefox 51
Unspecified
Android
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox49 unaffected, firefox50 unaffected, firefox51 verified)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

2 years ago
STR:

1) Open 2 tabs with web content.
2) Switch between tabs.

Expected: Content of selected tab is displayed.
Actual: The Content of the previous frame is displayed for a very brief moment causing the content to appear to flash.

It looks to me like content of the selected tab needs to be recomposited or at least cleared sooner and that the flash of previous content is just what was last composited to the surface.
(Assignee)

Comment 1

2 years ago
Created attachment 8787362 [details]
Example of content flash.
I've seen this a lot as well, we should definitely fix.
Keywords: regression, regressionwindow-wanted
Priority: -- → P2
Version: Trunk → 51 Branch
(Assignee)

Comment 3

2 years ago
I did a mozregression and found Bug 1291373 to be the cause.
(Assignee)

Updated

2 years ago
Keywords: regressionwindow-wanted
(Assignee)

Updated

2 years ago
Assignee: nobody → rbarker
Blocks: 1291373
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
(Assignee)

Comment 5

2 years ago
Created attachment 8787446 [details] [diff] [review]
0001-Bug-1299922-Keep-surface-covered-until-it-has-been-painted-when-switching-tabs-in-Fennec-r-jchen-16090116-8baf8db.patch
(Assignee)

Updated

2 years ago
Attachment #8787446 - Flags: review?(nchen)
(Assignee)

Updated

2 years ago
Depends on: 1297853
Attachment #8787446 - Flags: review?(nchen) → review+
(Assignee)

Comment 6

2 years ago
Created attachment 8787803 [details] [diff] [review]
0001-Bug-1299922-Keep-surface-covered-until-it-has-been-painted-when-switching-tabs-in-Fennec-r-jchen-16090216-9ae6b95.patch

Updated to reflect updates in Bug 1297853.
Cary forward r+ from :jchen
Attachment #8787446 - Attachment is obsolete: true

Comment 7

2 years ago
Pushed by rbarker@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/eb90834c4f10
Keep surface covered until it has been painted when switching tabs in Fennec r=jchen

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/eb90834c4f10
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox51: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Verified as fixed on 51 Beta 9;
Device: Nexus 9 (Android 7.0) and Asus Transformer Pad (Android 4.2.1).
status-firefox51: fixed → verified
You need to log in before you can comment on or make changes to this bug.