window.alert broken for tabs opened in RDM even after closing RDM

VERIFIED FIXED

Status

P1
normal
VERIFIED FIXED
2 years ago
3 months ago

People

(Reporter: jryans, Assigned: jryans)

Tracking

unspecified
Dependency tree / graph

Firefox Tracking Flags

(firefox52 verified)

Details

(Whiteboard: [multiviewport][reserve-rdm])

(Assignee)

Description

2 years ago
STR:

1. data:text/html,<script>onclick=function(){alert('ok')}</script>
2. Click to trigger alert, works in a regular tab
3. Open in new RDM
4. Click to trigger alert, expected to fail there, this is bug 1273997
5. Close RDM
6. Click to trigger alert

ER:

It should start working again now that RDM is closed.

AR:

It continues to fail outside of RDM and remains broken for the life of that tab.
(Assignee)

Updated

2 years ago
See Also: → bug 1273997

Updated

2 years ago
Iteration: --- → 51.3 - Sep 12
Flags: qe-verify+
QA Contact: mihai.boldan
(Assignee)

Updated

2 years ago
Depends on: 1301514
(Assignee)

Comment 1

2 years ago
This should now be fixed by bug 1301514.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
I managed to reproduce this issue on Firefox 50.0a1 (2016-07-27), under Windows 10 x64.
The issue is no longer reproducible on Firefox 51.0a1 (2016-09-14), under Windows 10x64, using STR from Comment 0.
On Mac OS X 10.11.1 and on Ubuntu 16.04 x64 the script from Comment 0 is not working, so I used the following script for testing this bug "javascript:onclick=function(){alert('ok')}".
Ryan, is this fix covered by this script on Ubuntu and Mac OS's?
Please let me know if there are any other tests that need to be performed around this issue.
QA Whiteboard: [qe-rdm]
Flags: needinfo?(jryans)
(Assignee)

Comment 3

2 years ago
(In reply to Mihai Boldan, QA [:mboldan] from comment #2)
> I managed to reproduce this issue on Firefox 50.0a1 (2016-07-27), under
> Windows 10 x64.
> The issue is no longer reproducible on Firefox 51.0a1 (2016-09-14), under
> Windows 10x64, using STR from Comment 0.
> On Mac OS X 10.11.1 and on Ubuntu 16.04 x64 the script from Comment 0 is not
> working, so I used the following script for testing this bug
> "javascript:onclick=function(){alert('ok')}".
> Ryan, is this fix covered by this script on Ubuntu and Mac OS's?
> Please let me know if there are any other tests that need to be performed
> around this issue.

Hmm, I was able to test this issue by pasting the URL from comment 0 step 1 into a new tab's location bar on Mac and Ubuntu.  Is this what you did as well?  Maybe I was too vague by just including the URL...?

In any case, alerts are meant to be working for all OSes after exiting RDM with this change.
Flags: needinfo?(jryans) → needinfo?(mihai.boldan)
It seems that the script is working on Mac OS X and Ubuntu OSs too. I'm not sure what I was doing wrong.
The issue was tested on Firefox 52.0a1 (2016-09-28), under Windows 10x64, Mac OS X 10.11.6 and under Ubuntu 16.04 x64.
I am marking this issue Verified Fixed since is not reproducible on the Latest Nightly.
Status: RESOLVED → VERIFIED
status-firefox52: --- → verified
Flags: qe-verify+
Flags: needinfo?(mihai.boldan)

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.