Closed Bug 1300338 Opened 4 years ago Closed 4 years ago

URL (from Google) causes hang on multiple machines and Windows 10 versions

Categories

(Core :: Graphics, defect, P3, major)

48 Branch
Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox48 --- wontfix
firefox49 + wontfix
firefox-esr45 --- unaffected
firefox50 + wontfix
firefox51 + fixed
firefox52 --- fixed

People

(Reporter: dtresearch, Assigned: bas.schouten)

References

(Depends on 1 open bug, Blocks 1 open bug, )

Details

(Keywords: hang, regression, reproducible, Whiteboard: gfx-noted)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

Go to URL https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=7&cad=rja&uact=8&ved=0ahUKEwjeh8DgzPPOAhUHyWMKHWxXDTMQFghKMAY&url=http%3A%2F%2Faperiodical.com%2F2014%2F11%2Fan-alan-turing-expert-answers-your-the-imitation-game-questions%2F&usg=AFQjCNERgGT3co3w46B3V4SrhQMsCXZqhQ


Actual results:

The address bar transitions from the Google URL to the actual URL. The page seems to load. After a few seconds the little spinner in the tab freezes. After this, any attempt to interact with Firefox results in the "Not Responding" message in the title bar. It may still be closed by right-clicking the task bar and clicking "close", which has to be done twice, or via the Task Manager. The window will still minimize and restore while in this state. On the 8 core computer the Task manager shows Firefox at 12.5-14.4% constantly, indicating 100% for the task. The two computers initially showing the problem are Windows 10 build 10586. These computers evolved independently, they are not clones. I also recreated the problem on an "almost virgin" dual-core running Windows 10 Build 14393.rs1_release_inmarket.160819-1924 and the "latest" Firefox as of August 2016. The CPU on this machine for the task is at 51-54% indicating 100% for the task. I also recreated the problem on a quad-core laptop running 10586.


Expected results:

Going to the URL with IE 11 results in the page loading and scrolling normally. It also seems to open normally on Windows 7 Ultimate build 7601, although there is a slight hiccup at the point where it would otherwise hang. There also were normal results on a "well worn" Windows XP SP3 Build 2600.xpsp_sp3_qfe.130704-0421, a dual-core desktop running Windows 7 Pro 32 bit build 7601, a dual-core laptop running Windows 10 Home build 10240, a quad-core desktop running Windows 8 Pro Build 9200, and a dual-core desktop running Windows 8.0 Pro build 9200.
Severity: normal → minor
OS: Unspecified → Windows 10
[Tracking Requested - why for this release]: Browser hangs

#1 With HWA, Firefox hangs.
#2 Without HWA, Fierfox does not hang. Blank page is shown, but there are invisible links.
   (I will file the other new bug for #2 problem.)


#1 Regression window:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=36c1e4eb0c9141aae4071a917ce4e3a59f5a79c6&tochange=d74084d072f0b5dfb00e3fbc103bef0a3fecbf85

#1 Regressed by: Bug 1220629
Blocks: 1220629
Status: UNCONFIRMED → NEW
Component: Untriaged → Graphics
Ever confirmed: true
Keywords: hang, reproducible
Product: Firefox → Core
> #2 Without HWA, Fierfox does not hang. Blank page is shown, but there are invisible links.
   (I will file the other new bug for #2 problem.)
please ignore this. 

It seems no problem without HWA
Track for 49+/50+/51+ as this is a reproducible behavior and hang issue with HWA.
Can reproduce on current nightly. Hangs browser straight away.
Whiteboard: gfx-noted
Assignee: nobody → bas
Status: NEW → ASSIGNED
Flags: needinfo?(bas)
See Also: → 1293586
In investigating this bug I've found an obvious performance optimization that as a side-effect fixes this bug. Patch upcoming.
Regression from Firefox 46, too late to fix this in 49. We can still take a patch for 50 though.
Comment on attachment 8790329 [details]
Bug 1300338: Do not attempt to preserve layer content when we're going to override it in a blend operation anyway.

https://reviewboard.mozilla.org/r/78216/#review77340
Attachment #8790329 - Flags: review?(jmuizelaar) → review+
Pushed by bschouten@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1fef8a245875
Do not attempt to preserve layer content when we're going to override it in a blend operation anyway. r=jrmuizel
Bulk move of gfx-noted bugs without priority to P3 for tracking.
Priority: -- → P3
Pushed by bschouten@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/13fe99de32f6
Do not attempt to preserve layer content when we're going to override it in a blend operation anyway. r=jrmuizel
https://hg.mozilla.org/mozilla-central/rev/13fe99de32f6
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Flags: needinfo?(bas)
Hi :bas,
Since this bug also affects 50/51, do you think the patch is worth uplifting to 50/51?
Flags: needinfo?(bas)
(In reply to Gerry Chang [:gchang] from comment #14)
> Hi :bas,
> Since this bug also affects 50/51, do you think the patch is worth uplifting
> to 50/51?

50, yes, 51, it depends a little bit. The patch is not entirely risk free. It could potentially cause some graphics artifacts although so far it seems it doesn't.
Flags: needinfo?(bas)
Hello David, could you please verify this issue is fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(dtresearch)
What is the "latest Nightly build" and where do I get it?
After many years in mainframe DP, this is my first exposure to open source.
Thanks for all the work. 
I immediately turned off hardware acceleration on all my computers as soon as I became aware of it.
It's the build of Firefox which contains the most recent changes (as of the previous night). You can download it from https://nightly.mozilla.org/
Hi Bas, based on comment 15, I assume you want this wontfix'd for 50. Or are you more comfortable uplifting now that this has been in Nightly for a few weeks?
Flags: needinfo?(bas)
Hi :milan,
Can you help create a uplift request for 51 aurora?
Flags: needinfo?(milan)
Comment on attachment 8790329 [details]
Bug 1300338: Do not attempt to preserve layer content when we're going to override it in a blend operation anyway.

Approval Request Comment
[Feature/regressing bug #]: 1220629
[User impact if declined]: A website doing some very specific actions may take a very long time to complete (hang)
[Describe test coverage new/current, TreeHerder]: Extensive nightly testing
[Risks and why]: Somewhat, this could cause some artifacts with complex blending.
[String/UUID change made/needed]: None
Flags: needinfo?(milan)
Flags: needinfo?(bas)
Attachment #8790329 - Flags: approval-mozilla-aurora?
Given the risk associated with this uplift and the fact that we are entering RC mode on Monday, this is now a wontfix for 50.
Comment on attachment 8790329 [details]
Bug 1300338: Do not attempt to preserve layer content when we're going to override it in a blend operation anyway.

Fix a hang issue. Take it in 51 aurora.
Attachment #8790329 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Depends on: 1532749

This problem went away.

Flags: needinfo?(dtresearch)
You need to log in before you can comment on or make changes to this bug.