[Static Analysis][Big parameter passed by value] In function HTMLMediaElement::SetMediaInfo

RESOLVED DUPLICATE of bug 1300459

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 1300459
2 years ago
2 years ago

People

(Reporter: andi, Assigned: andi)

Tracking

(Blocks: 1 bug, {coverity})

Trunk
coverity
Points:
---

Firefox Tracking Flags

(firefox51 affected)

Details

(Whiteboard: CID 1372416)

Attachments

(1 obsolete attachment)

(Assignee)

Description

2 years ago
The Static Analysis tool Coverity detected that |aInfo| is passed to SetMediaInfo as value and because of it's size it could be pass by reference.
Comment hidden (mozreview-request)

Comment 2

2 years ago
mozreview-review
Comment on attachment 8788106 [details]
Bug 1300500 - pass variable to SetMediaInfo as reference.

https://reviewboard.mozilla.org/r/76698/#review74822
Attachment #8788106 - Flags: review?(amarchesini) → review+
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1300459
(Assignee)

Updated

2 years ago
Attachment #8788106 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.