Closed Bug 1300734 Opened 3 years ago Closed 3 years ago

[HiDPI] tabs sometimes move on hover at 125% scale

Categories

(Firefox :: Theme, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 51
Tracking Status
firefox51 --- fixed

People

(Reporter: dao, Assigned: dao)

References

(Depends on 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Probably a regression from bug 1224732 and another manifestation of bug 477157.
Yes, I use Nightly with screen resolution at 125% on 1080p display and every time I hover over a background tab, favicon, title and close button move to the right.

It's easy to reproduce: open 2 or 3 random websites then 10 blank new tabs, then move the mouse over 1st tabs.
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c6906f5fc27809e2775e88a2ccc88fb794c93f4d&tochange=1789229965bfc5e7b08dfcf1c054c366abe1267a
I expect this is because of the negative margin (which doesn't get snapped the same way as the border width) not matching the width of the element (which is now only determined by the width of the border). If that suspicion is correct, putting back the width: 1px would fix this.
Attached patch patch (obsolete) — Splinter Review
Attached patch patchSplinter Review
Attachment #8788477 - Attachment is obsolete: true
Attachment #8788757 - Flags: review?(gijskruitbosch+bugs)
Attachment #8788757 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2e5a6cf43b46
Set width on tab separators to match their negative margin. r=gijs
https://hg.mozilla.org/mozilla-central/rev/2e5a6cf43b46
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
You need to log in before you can comment on or make changes to this bug.