Closed Bug 1300805 Opened 3 years ago Closed 3 years ago

Disable WebVTT breaks some controls of the native media player

Categories

(Toolkit :: Video/Audio Controls, defect)

50 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla51
Tracking Status
firefox49 --- unaffected
firefox50 + verified
firefox51 + verified

People

(Reporter: antonio_mario_novo, Assigned: rillian, NeedInfo)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160904030201

Steps to reproduce:

Create/use a new/clean profile;
Disable WebVTT by setting media.webvtt.enabled to false;
Play any media (even audio only tracks present the issue) using the browser embed media player, example:
http://techslides.com/demos/sample-videos/small.webm


Actual results:

Notice the lack of properties and feedback about the playback on the embed media player.
Some controls work, like setting the volume, but there is no feedback in the interface about the changes made, not even the playing progress is tracked.


Expected results:

Embed player UI should correctly display the playback properties when WebVTT is disabled.
Reg range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c9edfe35619f69f7785776ebd19a3140684024dc&tochange=437fc937572dd344f58226d40ba9eccb4ffcaedb

Ray Lin — Bug 887934 - Add closed caption button to video control. r=jaws
Blocks: 887934
Status: UNCONFIRMED → NEW
Component: Untriaged → Video/Audio Controls
Ever confirmed: true
Flags: needinfo?(ralin)
Keywords: regression
OS: Unspecified → All
Product: Firefox → Toolkit
Hardware: Unspecified → All
Version: 51 Branch → 50 Branch
Summary: Disable WebVTT breaks the embed media player → Disable WebVTT breaks some controls of the native media player
Ray, can you include a test that uses the closed captioning menu as part of this patch?
okay, no problem.

It's a good starting point for me to write test. Thank you Jared.
Assignee: nobody → ralin
Flags: needinfo?(ralin)
Tracking 51+ for this regression.
Status: NEW → ASSIGNED
Note Firefox 50 enters beta soon...
Can I ask a dumb question? Is there a reason to keep support for the media.webvtt.enabled pref?
None that I know of. This bug looked like a good way to add tests here.

Ralph, is this pref worth keeping around?
Flags: needinfo?(giles)
It is not. Let's remove it.
Flags: needinfo?(giles)
Comment on attachment 8791802 [details]
Bug 1300805 - Remove media.webvtt.enabled pref.

https://reviewboard.mozilla.org/r/79078/#review77706
Attachment #8791802 - Flags: review?(kinetik) → review+
Sorry about the relay in response -- Taipei is on holiday from Sep 15-16.
Assignee: ralin → giles
No worries. This is just waiting on dom peer review.
Comment on attachment 8791802 [details]
Bug 1300805 - Remove media.webvtt.enabled pref.

https://reviewboard.mozilla.org/r/79078/#review77858
Attachment #8791802 - Flags: review?(bugs) → review+
Pushed by rgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cf19bbf00b0e
Remove media.webvtt.enabled pref. r=kinetik,smaug
https://hg.mozilla.org/mozilla-central/rev/cf19bbf00b0e
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
Hi Ralph, should we uplift this fix to Beta50?
Flags: needinfo?(giles)
Tracked since it's a recent regression in Fx50.
Hmm, it's early in the cycle, so sure. Triggering the regression requires setting a non-default pref though, so it's not a big deal either way.
Flags: needinfo?(giles)
Approval Request Comment
[Feature/regressing bug #]: 1300805
[User impact if declined]: (Regression) Unresponsive media playback controls for users who set a non-default pref.
[Describe test coverage new/current, TreeHerder]: Landed on m-c before it went to aurora. No changes in default behaviour.
[Risks and why]: Risk is some side effect of removing the pref will affect other behaviour. However, the pref has been on by default for many releases, so I think this is not important. It may be surprising to remove the pref in beta at the same time as dev edition, but I think avoiding broken controls is more important.
[String/UUID change made/needed]: None
Attachment #8794399 - Flags: approval-mozilla-beta?
Hello Antonio, could you please verify this issue is fixed as expected on a latest Nightly build? Thanks!
Flags: needinfo?(antonio_mario_novo)
Comment on attachment 8794399 [details] [diff] [review]
Backport to beta 50

Removing a perf that has been on by default for a few releases and as such the pref is not needed anymore, Beta50+
Attachment #8794399 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Reproduced the initial behavior using old Nightly from 2016-09-06, verified that using latest builds, Firefox 50 beta 2, latest Developer Edition 51.0a2 and latest Nightly 52.0a1 across platforms (Mac OS X 10.10.5, Windows 10 64-bit and Ubuntu 16.04 32-bit) the issue is no longer reproducible due to the removal of pref "media.webvtt.enabled"
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.