Closed Bug 1301212 Opened 3 years ago Closed 3 years ago

Add xpcshell code coverage collection task to linux64-ccov.

Categories

(Testing :: Code Coverage, defect)

defect
Not set

Tracking

(firefox52 fixed)

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: sparky, Assigned: cody_tran95)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We need to be able to collect c++ code coverage data from the linux64-ccov build. This can be done by the same means as the mochitest-browser-chrome-ccov test is made. The flag used to enable it should be "--code-coverage" if it works, otherwise some things will have to be fixed.
Blocks: 1301170
Status: UNCONFIRMED → NEW
Ever confirmed: true
specifically here I believe the work is to make sure we run the xpcshell job on a build that is compiled with coverage enabled?  Possibly we need to add flags to the harness to set environment variables and prefs, but I don't think we do.  if we want to get data from the JS Engine (which currently is partially complete) then we need to set environment variables which is usually done at the harness level.

The simple answer here is adding code to schedule xpcshell tests on the linux64-ccov- once that is going we can work on the other parts.
Assignee: nobody → cody_tran95
Comment on attachment 8803113 [details]
Bug 1301212 - Enabled code coverage for xpcshell.

https://reviewboard.mozilla.org/r/87344/#review86400

Good job, just a couple small things to take care of.

::: taskcluster/ci/desktop-test/tests.yml:500
(Diff revision 1)
> +            linux64-ccov/opt: 7200
> +            linux64/debug: 5400
> +            default: 5400

No need for the extra option for linux64/debug since it is the same as default. Also, do we need 2 hours for max-run-time or can this be reduced?

::: taskcluster/ci/desktop-test/tests.yml:503
(Diff revision 1)
> +    e10s:
> +        by-test-platform:
> +            linux64-ccov/opt: false
> +            default: false

Since default is false, we can remove the by-test-platform option.
Attachment #8803113 - Flags: review?(gmierz2) → review-
Comment on attachment 8803113 [details]
Bug 1301212 - Enabled code coverage for xpcshell.

https://reviewboard.mozilla.org/r/87344/#review86532

outside of Greg's comments, these changes look great.  Pleaes address Greg's two comments :)
Attachment #8803113 - Flags: review?(jmaher) → review+
Comment on attachment 8803113 [details]
Bug 1301212 - Enabled code coverage for xpcshell.

https://reviewboard.mozilla.org/r/87344/#review86400

> No need for the extra option for linux64/debug since it is the same as default. Also, do we need 2 hours for max-run-time or can this be reduced?

Changed max-run-time to 5400 and it worked

https://treeherder.mozilla.org/#/jobs?repo=try&revision=4f3fbcab2a2f
Comment on attachment 8803113 [details]
Bug 1301212 - Enabled code coverage for xpcshell.

https://reviewboard.mozilla.org/r/87344/#review87470

Nice work Cody! I say this can be landed now.
Attachment #8803113 - Flags: review?(gmierz2) → review+
can you rebase this commit?  autoland failed to rebase, can you do it manually and then repush to mozreview?

here are some general guidelines and you can find the rebase stuff on there:
http://mozilla-version-control-tools.readthedocs.io/en/latest/hgmozilla/firefoxworkflow.html
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/23e68db8afd7
Enabled code coverage for xpcshell. r=gmierz2+560562,jmaher
Comment on attachment 8803113 [details]
Bug 1301212 - Enabled code coverage for xpcshell.

https://reviewboard.mozilla.org/r/87344/#review88420

::: taskcluster/ci/desktop-test/tests.yml:585
(Diff revision 3)
> +            by-test-platform:
> +                linux64-ccov/opt:
> -            - --xpcshell-suite=xpcshell
> +                    - --xpcshell-suite=xpcshell
> +                    - --code-coverage
> +                default:
> +                    - -xpcshell-suite=xpcshell

this was backed out for failures- the non code coverage command (like 585 here), needs --xpcshell instead of -xpcshell (notice the two dashes).
Attachment #8803113 - Flags: review+ → review-
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5612fd602e57
Backed out changeset 23e68db8afd7 for breaking XPC tests on a CLOSED TREE
Comment on attachment 8803113 [details]
Bug 1301212 - Enabled code coverage for xpcshell.

https://reviewboard.mozilla.org/r/87344/#review88538
Attachment #8803113 - Flags: review?(jmaher) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/54b73853d144
Enabled code coverage for xpcshell. r=gmierz2+560562,jmaher
https://hg.mozilla.org/mozilla-central/rev/54b73853d144
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Attachment #8803113 - Flags: review?(cmanchester)
You need to log in before you can comment on or make changes to this bug.