HLS videos automatically start playing when auto-play is OFF

RESOLVED FIXED in Firefox 56

Status

()

Firefox for Android
Audio/Video
RESOLVED FIXED
a year ago
5 months ago

People

(Reporter: Ninu, Assigned: snorp)

Tracking

(Depends on: 1 bug, {platform, qablocker})

Trunk
Firefox 56
ARM
Android
platform, qablocker
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, fennec+, firefox50 wontfix, firefox51 wontfix, firefox54 wontfix, firefox55 wontfix, firefox56 fixed)

Details

(Reporter)

Description

a year ago
Environment: Aurora (50.0a2 07.09.2016)
Device: Samsung Galaxy S6 Edge (Android 6.0);
Build: Aurora 50.0a2 (2016-09-07);

Steps to reproduce:
1. So to settings and make sure Autoplay is OFF
2. Go to goo.gl/LLxEY8 and click on the HLS video

Expected result:
The video should not start autoplaying

Actual result:
Video starts auto-playing ignoring Autoplay setting.
Assignee: nobody → snorp
tracking-fennec: ? → 50+
Keywords: platform
tracking-fennec: 50+ → +
Tested with LG G4 (Android 5.1) and Asus ZenPad 8 Android (6.0.1) and couldn't reproduce this on latest Nightly (56.0a1 from 2017/06/21).
Videos: goo.gl/LLxEY8 and https://www.nytimes.com/video/us/politics/100000005176480/karen-handel-wins-georgia-6th-district.html?smid=pl-share.
Per comment 1 and this bug should be fixed in bug 1345752, so close this bug.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Depends on: 1345752
Resolution: --- → FIXED
status-firefox50: affected → wontfix
status-firefox51: affected → wontfix
status-firefox54: --- → wontfix
status-firefox55: --- → wontfix
status-firefox56: --- → fixed
Target Milestone: --- → Firefox 56
You need to log in before you can comment on or make changes to this bug.