Closed Bug 1301415 Opened 6 years ago Closed 5 years ago

dom.ipc.processCount > 1 seems to result in multiple master password prompts

Categories

(Core :: DOM: Content Processes, defect, P1)

50 Branch
defect

Tracking

()

RESOLVED WORKSFORME
Iteration:
55.2 - Apr 3
Tracking Status
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 + wontfix
firefox55 + wontfix

People

(Reporter: mconley, Assigned: mrbkap)

References

Details

(Keywords: regression, Whiteboard: [e10s-multi:+])

I currently have dom.ipc.processCount set at 2. I also have a master password set for my default profile.

Each morning when I update and restart Nightly, I get 2 master password dialogs - one right after the other. I'm not sure what's triggering that dialog (perhaps sync?), but it'll show up soon after my session starts, and there's always 2. If I reduce my dom.ipc.processCount back down to 1, I only get the 1.

We should probably only have the one prompt, if possible.
Whiteboard: [e10s-multi:?]
Assignee: nobody → mrbkap
Iteration: --- → 55.2 - Apr 3
Whiteboard: [e10s-multi:?] → [e10s-multi:+]
Tracking 54/55+ for this regression.
Suspect this should block, even if the feature isn't commonly used.
Priority: -- → P1
I'll note that this might have fixed itself. I still use a master password, and I don't think I've been spammed by 4 prompts since we upped the process count... will pay more attention now.
I currently get two consecutive prompts in Nightly; dom.ipc.processCount is set to 4
Is this the same as bug 177175?
I don't think so as bug 177175 is 15 years old, but this is new for me in Nightly. BTW, I got three prompts, which might have been true the other day as well and I just confused one as me mistyping the PW. In my Dev Edition dom.ipc.processCount is set to 4 as well nd I only get one prompt.
I just now tried a different profile with Nightly (now pinned tabs, no tabs I needed a login on startup) and only got one prompt.
This doesn't seem to be an issue anymore, marking WONTFIX. If you see this again please re-open this issue.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
Per comment #8, mark 54 won't fix.
You need to log in before you can comment on or make changes to this bug.