collectstats.pl header incorrect.

RESOLVED DUPLICATE of bug 16009

Status

()

Bugzilla
Reporting/Charting
--
major
RESOLVED DUPLICATE of bug 16009
16 years ago
5 years ago

People

(Reporter: Chema Celorio, Assigned: gerv)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The header that collectstats is generating does not corresponds to the columns,
not only the header has one column less but the order of the fields do not match
because the order in which they are listed in collectstats is different than the
order in which they are listed in the default configuration.

Collect stats should not hardcode severity and resolutions. You'll find a patch
attached that solves this issue in a generic way.

regards,
Chema
(Reporter)

Comment 1

16 years ago
Created attachment 73599 [details] [diff] [review]
patch against collect stats

Updated

16 years ago
Keywords: patch, review
> The header that collectstats is generating does not corresponds to the 
> columns, not only the header has one column less but the order of the fields 
> do not match because the order in which they are listed in collectstats is 
> different than the order in which they are listed in the default 
> configuration.

I'm very sceptical that this is the case, because it would mean everyone's
charts would be wrong. To convince me, you will need to be more specific. :-)

What do you mean by "the order they are listed in the default configuration"?
Please give both orders, and point out how they are different, and what problems
it causes.

> Collect stats should not hardcode severity and resolutions. You'll find a patch
> attached that solves this issue in a generic way.

Even if there is a bug, this patch cannot be checked in, because there would be
serious migration issues. There is no guarantee that the lists you use would
produce the same fields in the same order, and so people's data fields may get
messed up.

Gerv
(Reporter)

Comment 3

16 years ago
Hmm, yes.

I think you are right, i backported a patch to the Ximian's bugzilla
installation and i overlooked a detail. I'll provide a new patch that doesn't
break current installations.

my mistake.
Chema
Please don't provide another patch until you explain what the problem is more
clearly :-)

The fact that collectstats.pl is not generic is not, in itself, a problem - this
will go away when we get generic charting, and the data moves into the database.
This is bug 16009.

Gerv
(Reporter)

Comment 5

16 years ago
I'm closing the bug as a dulpicate of 16009

*** This bug has been marked as a duplicate of 16009 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.