Firefox Sync Deleted Bookmarks

RESOLVED DUPLICATE of bug 1343103

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1343103
2 years ago
a year ago

People

(Reporter: wtds.trabalho, Unassigned)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Android 4.4.4; Mobile; rv:51.0) Gecko/51.0 Firefox/51.0
Build ID: 20160908030434

Steps to reproduce:

Delete and reorganize more than a 70.000 bookmarks. 
After sync te deleted and reordered bookmarks return and duplicate again. 

Please when delete bookmark and previously sync deletes. 
I trying to delete and solve sync problems but still complicated 


Actual results:

Sync resuscitate deleted bookmarks. 
Sync recreate deleted bookmarks folders. 

Library window are very slow and have a dozens of problems. 


Expected results:

When delete from one host delete from all hosts. 
Allow to manage large amounts of bookmarks. 


Sorry but I need help...

Updated

2 years ago
Component: Untriaged → Sync
You should try disabling the Sync of all bookmarks, then organize your bookmarks, then re-enable bookmark syncing. Please let us know how that goes.
Flags: needinfo?(wtds.trabalho)
(Reporter)

Comment 2

2 years ago
I tried. But was synced the  bookmarks from other clients.

The problem is  the not syncing of deleted bookmarks before syncing the local bookmarks 

Sorry my poor English.
(Reporter)

Comment 3

2 years ago
Please contact me if you need more details.

I turned off sync for this moment but I need turn on again.
Flags: needinfo?(wtds.trabalho) → needinfo?(markh)
(In reply to Wellington Torrejais da Silva from comment #2)
> I tried. But was synced the  bookmarks from other clients.

If you disable bookmarks on your device, then perform a sync, the bookmarks on the server are deleted. If you then re-enable bookmarks, then clients will re-send their bookmarks to the server. If you have other clients with bookmarks that you don't want on the server, you should disconnect that client from Sync before performing the above - then only the bookmarks from your connected bookmarks should end up on the server.
Flags: needinfo?(markh)
(Reporter)

Comment 5

2 years ago
(In reply to Mark Hammond [:markh] from comment #4)
> (In reply to Wellington Torrejais da Silva from comment #2)
> > I tried. But was synced the  bookmarks from other clients.
> 
> If you disable bookmarks on your device, then perform a sync, the bookmarks
> on the server are deleted. If you then re-enable bookmarks, then clients
> will re-send their bookmarks to the server. If you have other clients with
> bookmarks that you don't want on the server, you should disconnect that
> client from Sync before performing the above - then only the bookmarks from
> your connected bookmarks should end up on the server.

It's not easily when have many devices.
But i will try this solution.

There is a page to check bookmarks in a server?
Flags: needinfo?(markh)
https://addons.mozilla.org/en-US/firefox/addon/about-sync/ can tell you what is on the server. Once you disable bookmarks and Sync, you should find that bookmarks vanishes from the list of collections. When you enable it and sync this device, you should see the bookmarks from this device appear (but also bookmarks from other devices as they again start syncing bookmarks)
Flags: needinfo?(markh)

Updated

2 years ago
Priority: -- → P3
(Reporter)

Comment 7

2 years ago
(In reply to Mark Hammond [:markh] from comment #6)
> https://addons.mozilla.org/en-US/firefox/addon/about-sync/ can tell you what
> is on the server. Once you disable bookmarks and Sync, you should find that
> bookmarks vanishes from the list of collections. When you enable it and sync
> this device, you should see the bookmarks from this device appear (but also
> bookmarks from other devices as they again start syncing bookmarks)

I need your help.

It's hard to delete bookmarks. I have many devices.
I trying to delete some (15.000) Bookmarks one by one. (Before Enable sync)


But i got many problems using "Library Manager":
Script: chrome://browser/content/browser-places.js:1883
Script: chrome://browser/content/places/treeView.js:669
Script: chrome://browser/content/places/treeView.js:850
Script: chrome://browser/content/places/treeView.js:1123
Script: chrome://browser/content/places/editBookmarkOverlay.js:1128


I need many hours to try delete. A broken delete it is possible.

It's possible solve this for me?
Flags: needinfo?(markh)
(Reporter)

Comment 8

2 years ago
Created attachment 8792699 [details]
Captura de Tela (362).png

Broken delete.
Error on delete.

Hard to delete.
Flags: needinfo?(markh)
Another possibility you could consider is to "export" all your bookmarks to a file, manually edit that file in a text editor, then re-import them.
Storing tombstones permanently should fix this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1343103
You need to log in before you can comment on or make changes to this bug.