Unable to maximise videos on liveleak.com (Firefox mobile)

RESOLVED FIXED

Status

Tech Evangelism
Mobile
P3
normal
RESOLVED FIXED
a year ago
8 months ago

People

(Reporter: bug.zilla, Unassigned)

Tracking

({compat})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sitewait], URL)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160903004009

Steps to reproduce:

Visit liveleak.com and attempt to maximise a video


Actual results:

Video does not maximise


Expected results:

Video should maximise
(Reporter)

Updated

a year ago
Component: Untriaged → Audio/Video
Product: Firefox → Firefox for Android
Version: 50 Branch → 47 Branch
Ray, 
Can you help have a look?
Flags: needinfo?(ralin)
BTW,I can see this problem on my nightly.

Comment 3

a year ago
liveleak.com uses jwplayer v6.8. To trace the behavior back to version 6.8 (about 2.5 years ago), I found these lines of code [0]. For android, it should run into _isMobile block, however, it does something make no sense for Fennec(all version) to toggle fullscreen. In other hand, it was doing right on webkit based browser(see line: 373). 

It seems the only way is to try to ask liveleak.com upgrade jwplayer's version, otherwise we could not help with this issue.  
By the way, [1] is the latest fullscreen implementation of jwplayer, it should work fine.

[0] https://github.com/jwplayer/jwplayer/blob/v6.8.0/src/js/html5/jwplayer.html5.view.js#L361-L392
[1] https://github.com/jwplayer/jwplayer/blob/15fe00794cfbbef6e2d63c0c6023e82be4151ca9/src/js/view/view.js#L102-L107
Flags: needinfo?(ralin)
Ray, 
Thanks for your super fast check!
I will try to talk to liveleak to see if they can upgrade their JW player.
Keywords: compat
Priority: -- → P3
Component: Audio/Video → Mobile
Product: Firefox for Android → Tech Evangelism
Version: 47 Branch → unspecified
Mike - if we make this tech evangelism, will someone try to contact the site?
Flags: needinfo?(miket)
This issue is a duplicate of https://webcompat.com/issues/551
I tried to contact them a couple of times. My latest attempt was 21 days ago, where I had a human replying to me. I sent a message.
Flags: needinfo?(miket)
Whiteboard: [sitewait]
This seems to be fixed now -- fullscreen button works as expected.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.