Last Comment Bug 1301999 - Array indices lower than length of generic objects appear hidden in console
: Array indices lower than length of generic objects appear hidden in console
Status: VERIFIED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: Developer Tools: Console (show other bugs)
: 45 Branch
: Unspecified Unspecified
-- normal (vote)
: Firefox 51
Assigned To: Oriol
:
: (Unavailable until Apr 3) [:bgrins]
Mentors:
: 1231419 (view as bug list)
Depends on: 1314571 1317502
Blocks: 1035545
  Show dependency treegraph
 
Reported: 2016-09-11 17:57 PDT by Oriol
Modified: 2017-01-09 02:07 PST (History)
9 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
wontfix
wontfix
wontfix
verified


Attachments
generic-object-v1.patch (6.18 KB, patch)
2016-09-11 17:57 PDT, Oriol
nfitzgerald: review+
Details | Diff | Splinter Review

Description User image Oriol 2016-09-11 17:57:16 PDT
Created attachment 8790128 [details] [diff] [review]
generic-object-v1.patch

Enter a generic object with a length property and some array indices to the console:

    ({0: 0, 1: 1, 2: 2, 3: 3, length: 2})

The preview shows

    Object { 2: 2, 3: 3, length: 2, 2 more… }

instead of

    Object { 0: 0, 1: 1, 2: 2, 3: 3, length: 2 }

I wondered what was the point of doing that. It seems it was just a mistake of bug 1035545. It added an additional argument to GenericObject without realizing it was already called with a third argument.
Comment 1 User image Nick Fitzgerald [:fitzgen] [⏰PST; UTC-8] 2016-09-12 10:26:48 PDT
Comment on attachment 8790128 [details] [diff] [review]
generic-object-v1.patch

Review of attachment 8790128 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM!
Comment 2 User image Pulsebot 2016-09-13 18:54:54 PDT
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/b532ddbe9b41
Stop hiding array indices of generic objects in console. r=fitzgen
Comment 3 User image Carsten Book [:Tomcat] 2016-09-14 03:09:11 PDT
https://hg.mozilla.org/mozilla-central/rev/b532ddbe9b41
Comment 4 User image Oriol 2016-09-15 13:17:00 PDT
*** Bug 1231419 has been marked as a duplicate of this bug. ***
Comment 5 User image Maruf Rahman[:mMARUF] 2016-09-22 06:09:17 PDT
I have reproduced this bug with Nightly 51.0a1 (2016-09-11) (64-bit) on Windows 7 , 64 Bit !

This bug's fix is verified with latest Aurora (Developer Edition)

Build ID : 20160922004007
User Agent : Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
[bugday-20160921]
Comment 6 User image Kostas 2016-11-14 14:41:31 PST
There has been a regression and so this issue is present again in Nightly,
i.e. entering in Web Console:
    ({0: 0, 1: 1, 2: 2, 3: 3, length: 2})
the preview shows:
    Object { 2: 2, 3: 3, length: 2, 2 more… 

Regression window: https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=37f78aca862224d7151c0fcae1ed8373fe11c83b&tochange=a5510966f80b9b2f5abf59ab32cf4c92d66c60de

Among the changes pushed that day (2016-10-07) it was one for bug 1304178 ("Pref on the new console frontend in nightly").
This must have caused this.

In most current Dev edition 51.0a2 x64 (2016-11-14) the issue is not present - tested in win 10 x64.
(In Dev edition the old console is still enabled by default, so I suppose that's why the issue is not present there).
Comment 7 User image (Unavailable until Apr 3) [:bgrins] 2016-11-14 14:47:27 PST
(In reply to Kostas from comment #6)
> There has been a regression and so this issue is present again in Nightly,
> i.e. entering in Web Console:
>     ({0: 0, 1: 1, 2: 2, 3: 3, length: 2})
> the preview shows:
>     Object { 2: 2, 3: 3, length: 2, 2 more… 
> 
> Regression window:
> https://hg.mozilla.org/integration/fx-team/
> pushloghtml?fromchange=37f78aca862224d7151c0fcae1ed8373fe11c83b&tochange=a551
> 0966f80b9b2f5abf59ab32cf4c92d66c60de
> 
> Among the changes pushed that day (2016-10-07) it was one for bug 1304178
> ("Pref on the new console frontend in nightly").
> This must have caused this.
> 
> In most current Dev edition 51.0a2 x64 (2016-11-14) the issue is not present
> - tested in win 10 x64.
> (In Dev edition the old console is still enabled by default, so I suppose
> that's why the issue is not present there).

Thanks for the heads up.  I filed Bug 1317502 to track the fix for this in the Reps system that the new console frontend is using.
Comment 8 User image Ritu Kothari (:ritu) 2016-12-12 13:30:48 PST
Too late to fix in 50.1.0 release
Comment 9 User image Kazi Nuzhat Tasnem 2017-01-07 03:27:16 PST
I have reproduced this bug with Firefox nightly 51.0a1(build ID:20160911030419)on 
windows 7(64 bit)

I have verified this bug as fixed with Firefox beta 51.0b12(build ID:20170105155013)
User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

[testday-20170106]
Comment 10 User image Bogdan Maris, QA [:bogdan_maris] 2017-01-09 02:07:06 PST
(In reply to Kazi Nuzhat Tasnem from comment #9)
> I have reproduced this bug with Firefox nightly 51.0a1(build
> ID:20160911030419)on 
> windows 7(64 bit)
> 
> I have verified this bug as fixed with Firefox beta 51.0b12(build
> ID:20170105155013)
> User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101
> Firefox/51.0
> 
> [testday-20170106]

Thank you for verifying this bug!

Note You need to log in before you can comment on or make changes to this bug.