Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Windows 7 (Aero) Theme - Open Downloads Folder button contains separator and is not properly highlighted

RESOLVED INVALID

Status

()

Firefox
Downloads Panel
RESOLVED INVALID
10 months ago
10 months ago

People

(Reporter: roxana.leitan@softvision.ro, Unassigned)

Tracking

(Blocks: 1 bug)

51 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(firefox48 unaffected, firefox49 unaffected, firefox50 unaffected, firefox51 affected)

Details

(Whiteboard: [CHE-MVP][CHE-BUG])

Attachments

(3 attachments)

(Reporter)

Description

10 months ago
Created attachment 8790244 [details]
image.png

[Affected versions]:
- Nightly 51

[Affected platforms]:
- Windows 7

[Prerequisites]:
Activate Windows 7(Aero)Theme:
-Go to Personalize> Themes> Aero Themes> Windows 7

[Steps to reproduce]:
1.Launch Firefox with a new profile
2.Click the Downloads button from the toolbar
3.Click the dropdown arrow
4.Hover your mouse over Open Downloads Folder button

[Expected result]:
Open Downloads Folder button should be highlighted and should not contain separator

[Actual result]:
Open Downloads Folder button contains separator and is not properly highlighted 

[Regression range]:
Not a regression.
(Reporter)

Updated

10 months ago
status-firefox48: --- → unaffected
status-firefox49: --- → unaffected
status-firefox50: --- → unaffected
Created attachment 8792408 [details]
context menu at download item
Created attachment 8792409 [details]
dropmark menu
Hi Roxana,

(In reply to roxana.leitan@softvision.ro from comment #0)
> [Actual result]:
> Open Downloads Folder button contains separator and is not properly
> highlighted 
> 

The separator line is Windows 7 style. Please see attachment 8792408 [details].
You will see the highlight style in both attachment 8792408 [details] and attachment 8792409 [details].
I suppose the highlight style is correct in dropmarker menu.

May I know your thoughts?
Flags: needinfo?(roxana.leitan)
(Reporter)

Comment 4

10 months ago
Hi Sean,

Thanks for looking into it. Clearly you are right about the style being the same, therefore I think we can close this issue as invalid if you agree. IMHO, I am still a bit confused by the bookmarks menu, which doesn't contain the separator. I think the reason for which the dropmark looks weird with the separator style, at least to me, might be because it's hanging out there, unlike the menu items.
Flags: needinfo?(roxana.leitan)

Updated

10 months ago
Whiteboard: [CHE-MVP][CHE-BUG]

Comment 5

10 months ago
Closing as invalid per comment 4. I agree it's a bit weird for a context menu when there are no icons, but it's the platform style for all menus in all applications.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.