Closed Bug 1302352 Opened 3 years ago Closed 3 years ago

browser_context_menu_iframe.js is skipped in e10s

Categories

(Toolkit :: Password Manager, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla51
Tracking Status
e10s - ---
firefox51 --- fixed

People

(Reporter: evanxd, Assigned: evanxd)

Details

Attachments

(1 file)

The "browser_context_menu_iframe.js" test is skiped[1] on e10s environment. Let's re-enable it.

[1]: http://searchfox.org/mozilla-central/source/toolkit/components/passwordmgr/test/browser/browser.ini#56-57
Pushed a new try[1]: Re-enable the test to debug.

[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=513287064996
tracking-e10s: --- → ?
Re-trigger "browser_context_menu_iframe.js" test for multiple times to reproduce the intermittent failure.
The "browser_context_menu_iframe.js" test is passed for 50 times continuously. Looks like we can re-enable it.
Hi Matthew,

Let's re-enable the test. It is passed for 50 times continuously on the try[1].

Thanks for the review.

[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=513287064996
Attachment #8791086 - Flags: review?(MattN+bmo)
Pushed a try[1] for updating commit message.

[1]: https://treeherder.mozilla.org/#/jobs?repo=try&revision=d8b29a4285b6
Assignee: nobody → evan
I think it was just skipped because it was assumed that it should be since it was copied from browser_context_menu.js (which is disabled in e10s).
Summary: Intermittent e10s browser_context_menu_iframe.js → browser_context_menu_iframe.js is skipped in e10s
Attachment #8791086 - Flags: review?(MattN+bmo) → review+
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/fda5c90a13da
Re-enable browser_context_menu_iframe.js in e10s environment. r=MattN
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/fda5c90a13da
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla51
You need to log in before you can comment on or make changes to this bug.