Closed Bug 1302383 Opened 3 years ago Closed 3 years ago

Rename inspector.xul to inspector.xhtml

Categories

(DevTools :: Inspector, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1262443

People

(Reporter: Honza, Assigned: Honza)

References

Details

Attachments

(1 file)

In order to ensure real XHTML namespace in inspector.xul frame we need to change the extension to .xhtml.

This step is part of our effort to replace XUL by HTML.

Honza
Whiteboard: [devtools-html]
Attached patch bug1302383.patchSplinter Review
Here is preliminary patch. It's based on patches from bug 1260552 and a patch from bug 1294186.

Honza
Assignee: nobody → odvarko
Status: NEW → ASSIGNED
Try push:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=59c75ae3c64d

Test failures are mostly related to CSS property editing (Rule View) and clipboard (cut/copy/paste context menu items). A lot of failures might related to wrong focus management.

Honza
Isn't this a dupe of Bug 1262443 ? (blocked on your splitter bug at the moment)
Flags: needinfo?(odvarko)
(In reply to Julian Descottes [:jdescottes] from comment #3)
> Isn't this a dupe of Bug 1262443 ? (blocked on your splitter bug at the
> moment)
Ah, you are right. I totally forgot about that report.

Honza
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(odvarko)
Resolution: --- → DUPLICATE
Duplicate of bug: 1262443
Whiteboard: [devtools-html]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.