Closed Bug 1302974 Opened 5 years ago Closed 2 years ago

Firefox instantaneously crash on Google maps with Nouveau driver on Linux

Categories

(Core :: Graphics, defect, P3)

48 Branch
All
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
platform-rel --- -

People

(Reporter: jeremy9856, Unassigned)

References

Details

(Whiteboard: [gfx-noted] [platform-rel-Google][platform-rel-GoogleMaps])

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160819105407



Actual results:

Firefox instantaneously crash on Google maps with Nouveau driver on Linux.

Firefox 48.0.1
Fedora 24
Kernel 4.7.3
Severity: normal → major
OS: Unspecified → Linux
Priority: -- → P2
Hardware: Unspecified → All
Chromium work well.
Do you have a crash report?
https://developer.mozilla.org/en-US/docs/Mozilla/How_to_get_a_stacktrace_for_a_bug_report
Component: Untriaged → Graphics
Product: Firefox → Core
I couldn't manage to have a crash report for now. Firefox make the computer totally crash again. To be clear, when I experienced the bug for the first time, Firefox made the computer totally crash on Google Maps. These days it was only Firefox that crashed on Google Maps. But now, as I said, Firefox make the computer totally crash again.

I maybe have found the culprit. I should have said that I use a "user.js" file with these entries:

// PERFORMANCE
user_pref("layers.acceleration.force-enabled", true);
user_pref("layers.offmainthreadcomposition.enabled", true);
user_pref("layers.offmainthreadcomposition.async-animations", true);
user_pref("layout.frame_rate.precise", true);
user_pref("webgl.force-enabled", true);
user_pref("webgl.msaa-force", true);
user_pref("html5.offmainthread", true);

// PRIVACY
user_pref("loop.enabled", false);
user_pref("extensions.pocket.enabled", false);
user_pref("privacy.trackingprotection.enabled", true);
user_pref("geo.enabled", false);
user_pref("browser.safebrowsing.enabled", false);
user_pref("browser.safebrowsing.malware.enabled", false);
user_pref("dom.event.clipboardevents.enabled", false);
user_pref("browser.send_pings", false);
user_pref("dom.battery.enabled", false);

// USABILITY
user_pref("browser.tabs.loadBookmarksInBackground", true);

It seem that is "user_pref("layers.acceleration.force-enabled", true);" that make Firefox crash. If I set it to false Google Maps works. To confirm with a clean profile, Firefox crash on Google Maps with just this setting enabled "user_pref("layers.acceleration.force-enabled", true);". Weirdly it make Firefox crash only on Google Maps. Unfortunately I, and a lot of people I guess, need this feature to get rid of tearing.

I hope we can find a fix ! Thanks !
"layers.acceleration.force-enabled" is releated to hardware acceleration.

Does Firefox crash in safe mode (HWA is off in safe mode)?
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Anyway you can use your current profile with HWA disabled from the options:
https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration
Oh, and can you type about:support in the location bar and copy here the section "graphics".
Firefox doesn't crash in safe mode. It don't crash too with HWA disabled.

Here is the section "graphics"

Accélération graphique
Fonctionnalités
Composition	OpenGL
Zoom/Panoramique asynchrones	aucun
Rendu WebGL	nouveau -- Gallium 0.4 on NVC1
Décodage matériel H264	No
GPU 1
Actif	Oui
Description	nouveau -- Gallium 0.4 on NVC1
ID du vendeur	nouveau
ID du périphérique	Gallium 0.4 on NVC1
Version du pilote	3.0 Mesa 12.0.2
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend	skia
AzureContentBackend	cairo
AzureFallbackCanvasBackend	none
CairoUseXRender	0
A similar bug is reported against Nouveau

https://bugs.freedesktop.org/show_bug.cgi?id=97462
But since Chromium work well not sure if the problem is in part from Nouveau.
Whiteboard: [gfx-noted]
Right, you're forcing acceleration on the version of the driver that doesn't support it well.  It's likely Chrome would crash if you were to force acceleration there.  Good information though, identifying which driver version has problems, thanks!
Depends on: ogl-linux-beta
platform-rel: --- → ?
Whiteboard: [gfx-noted] → [gfx-noted] [platform-rel-Google][platform-rel-GoogleMaps]
I activated dri3 on nouveau (with the following user.js) and firefox doesn't crash anymore on google maps !

// PERFORMANCE
user_pref("layers.acceleration.force-enabled", true);
user_pref("layers.offmainthreadcomposition.enabled", true);
user_pref("layers.offmainthreadcomposition.async-animations", true);
user_pref("layout.frame_rate.precise", true);
user_pref("webgl.force-enabled", true);
user_pref("webgl.msaa-force", true);
user_pref("html5.offmainthread", true);
user_pref("gfx.content.azure.backends", "skia");
user_pref("browser.tabs.remote.force-enable", true);

// PRIVACY
user_pref("loop.enabled", false);
user_pref("extensions.pocket.enabled", false);
user_pref("privacy.trackingprotection.enabled", true);
user_pref("geo.enabled", false);
user_pref("browser.safebrowsing.enabled", false);
user_pref("browser.safebrowsing.malware.enabled", false);
user_pref("dom.event.clipboardevents.enabled", false);
user_pref("browser.send_pings", false);
user_pref("dom.battery.enabled", false);

// USABILITY
user_pref("browser.tabs.loadBookmarksInBackground", true);
user_pref("reader.parse-on-load.enabled", false);
user_pref("reader.parse-on-load.force-enabled", false);
platform-rel: ? → -
Seem to work with nouveau dri2 on Fedora 25.
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.