Does not select item in menu when using arrow keys

VERIFIED DUPLICATE of bug 126379

Status

()

Core
Keyboard: Navigation
--
major
VERIFIED DUPLICATE of bug 126379
15 years ago
15 years ago

People

(Reporter: Ryan WYler, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

In the example page you will find that you can select on the fields with the
mouse and it will do different things.  If you change the fields with the arrow
keys, it won't change the appropriate fields.  Not sure if this is a javascript
issue or just a browser issue.

Reproducible: Always
Steps to Reproduce:
1.  Goto web page at http://www.nhorizon.net/~ryan/mozilla_bug1.html
2.  Click on the field "category" 
3.  Use arrow keys to change the values, notice it doesn't change anything in
other fields. (only changes the current field)

Actual Results:  The only field that changes is one that you're moving the arrow
keys in.

Expected Results:  Mozilla should have done the javascript function that would
have changed the other fields.
(Assignee)

Comment 1

15 years ago
Created attachment 73704 [details]
Example #2 - same, but with more space between form controls

Same patch as above, but more space so that popup doesn't cover other form
controls.

It doesn't do anything for me script-wise whether I use the mouse or the
keyboard.
(Assignee)

Comment 2

15 years ago
Created attachment 73705 [details]
Example #2 - same, but with more space between form controls

Same patch as above, but more space so that popup doesn't cover other form
controls.

It doesn't do anything for me script-wise whether I use the mouse or the
keyboard.
What is it supposed to do exactly?

Comment 3

15 years ago
I am the one who requested Mozilla's current behavior (in bug 110800).  The 
reason I asked for onchange to not fire right away is that web developers who 
use onchange often make the assumption that the user will never temporarily 
select the wrong item before selecting the item they intend to select.  (This 
assumption is reasonable if the user selects an item using the mouse or if the 
user opens the dropdown menu with Alt+Down, but not if the user selects using 
just the arrow keys.)  Onchange fires when the user moves focus from the 
dropdown, for example by pressing the Tab key or by clicking somewhere else in 
the document.

If this turns out to be a major problem, we may reverse the change.  I think 
that navigation remains the main use of <select size=1 onchange=*>, though, and 
having to hit tab to make the rest of a form update isn't as bad as not being 
able to navigate a site.

(I'm testing http://www.nhorizon.net/~ryan/mozilla_bug1.html because I get 
JavaScript errors at the attached testcases.)

Comment 4

15 years ago
*** Bug 144174 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.