Attempting to install a Web Extension via about:debugging with an invalid structure gives only "Extension is invalid", not a detailed message

RESOLVED DUPLICATE of bug 1224591

Status

--
major
RESOLVED DUPLICATE of bug 1224591
2 years ago
4 months ago

People

(Reporter: standard8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I was attempting to install a web extension via about:debugging. In the extension manifest, I'd accidentally left in:

    "default_locale": "en",

(I was going to add localisation later).

When attempting to load it via about:debugging, all that Firefox told me was "There was an error during installation: Extension is invalid".

I did some debugging, in xpinstall, there's a proper error raised, it just doesn't get raised to the UI.

Please can it get raised up properly, it would help first time web extension developers a lot.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1224591

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.