Unable to resize Profile Manager

RESOLVED DUPLICATE of bug 385161

Status

()

Toolkit
Startup and Profile System
RESOLVED DUPLICATE of bug 385161
a year ago
a year ago

People

(Reporter: moz_bugzilla, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

a year ago
Created attachment 8791665 [details]
Screenshot_9_15_16__09_30.jpg

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36

Steps to reproduce:

Start Thunderbird 45.3.0 on OS X El Capitan 10.11.6 (15G1004). I obviously have multiple profiles configured and furthermore do not have a default (I expect to choose each and every time I start Tbird).


Actual results:

The profile manager seems to have randomly resized itself to a very small size. I vaguely recall this happening a few weeks ago and, at the same time, various other Tbird windows resized too. I was able to manually fix all Tbird windows except the profile manager, which seems uncontrollable. Please see the attached screenshot for a demonstration of what the window looks like on a MacBook Pro 15" Retina's default display (thus plenty of pixels and space).


Expected results:

All of the following:
1) Profile window shouldn't have ever resized (shrunk).
2) Profile window should be resize-able (especially useful for people who have long profile names)
3) A "resize to default" option should be available on the profile manager.
(Reporter)

Comment 1

a year ago
Note that I cannot find a workaround to manually resize the window.
I moved this to Thunderbird based on description.
Component: General → General
Product: Toolkit → Thunderbird
(Reporter)

Comment 3

a year ago
Fair enough, and apologies for possibly filing it in the wrong place.
Component: General → General
Product: Thunderbird → Firefox
Version: 45 Branch → Trunk
No, the profile manager is a FF piece, you get it if you start firefox with -p.
I don't think TB does anything special there. It can't be resized in FF either.
And while you're looking at the profile manager, I invite you to do this in a debug build to see this nice warning:

WARNING: YOU ARE LEAKING THE WORLD (at least one JSRuntime and everything alive inside it, that is) AT JS_ShutDown TIME.  FIX THIS!
[5444] WARNING: '!compMgr', file c:/mozilla-source/mozilla-central/xpcom/glue/nsComponentManagerUtils.cpp, line 63
Leaked URLs:
  chrome://mozapps/content/profile/profileSelection.xul
  resource://gre-resources/counterstyles.css
  chrome://global/content/minimal-xul.css
  resource://gre-resources/quirk.css
  resource://gre/res/svg.css
  chrome://global/content/xul.css
  chrome://global/skin/scrollbars.css
  resource://gre-resources/number-control.css

I'm not including the entire list that takes many seconds to pass on the debug console.

Updated

a year ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Component: General → Startup and Profile System
Product: Firefox → Toolkit
Resolution: --- → DUPLICATE
Duplicate of bug: 385161
What about the lovely debug message? Should I file another bug for that or is this also known?
Flags: needinfo?(gijskruitbosch+bugs)

Comment 8

a year ago
(In reply to Jorg K (GMT+2, never had any PTO during summer) from comment #7)
> What about the lovely debug message? Should I file another bug for that or
> is this also known?

Another bug. With more details - right now I have no idea if this shows up when you open the profile manager, when you close it, or when you close thunderbird or firefox or anything else after you open a profile from the profile manager, or something else still. It's also not clear if it reproduces with a clean profile on an official debug build, or just locally, or...
Flags: needinfo?(gijskruitbosch+bugs)
This bug was initially reported for TB. Since FF don't want to make their profile manager resizeable (bug 385161 was a WONTFIX), most likely because few FF users use the profile manager, perhaps we can do it in TB. If so, let's move the bug to a TB component and reopen it.
Flags: needinfo?(richard.marti)
Jörg, this would mean we need a fork. Is this desired?

moz_bugzilla, could you try to rename xulstore.json to something different with TB closed and then start TB? This will reset all appearance things like size, position, toolbar configs to default. And also the Profile manager should have it's default dimensions.

If this helps you can position your windows like you want again. If not, you can delete the newly created xulstore.json and rename the before renamed file back to the original name. But do this only with a closed TB.
Flags: needinfo?(richard.marti) → needinfo?(moz_bugzilla)
(In reply to Richard Marti (:Paenglab) from comment #10)
> Jörg, this would mean we need a fork. Is this desired?
No. I thought you can do some CSS trick somewhere. If you can't, we won't do anything.
(Reporter)

Comment 12

a year ago
Created attachment 8792565 [details]
xulstore-broken.json
(Reporter)

Comment 13

a year ago
Created attachment 8792566 [details]
xulstore-pristine.json
(Reporter)

Comment 14

a year ago
Created attachment 8792567 [details] [diff] [review]
xulstore-diff.diff
(Reporter)

Comment 15

a year ago
I tried that experiment, unfortunately it didn't help (sure, plenty of prefs reset to default but the profile manager's size and location are not things that got reset, unfortunately).

I don't think there's anything sensitive in this file so I've posted the original (broken?) version, the new (pristine) one, and a diff. Unfortunately I don't think my solution lies in this file.
Flags: needinfo?(moz_bugzilla)
Jörg, with CSS it's not possible because at the state when the profile Manager is shown nothing from messenger is loaded. What could work is the same as SM is doing: https://dxr.mozilla.org/comm-central/rev/f8b0b5f8d2ec7a8bcd4ebcf7c0e05054d4ef62f3/suite/common/jar.mn#5

But this would mean we have to maintain our own XUL file and have to look it's in synch with the toolkit one.
I really don't have an opinion. Maybe rather not for the time being. Thanks for the information.
You need to log in before you can comment on or make changes to this bug.