Closed Bug 1303185 Opened 3 years ago Closed 3 years ago

Multiple webrtc call at the same time permission error

Categories

(Firefox :: Site Permissions, defect)

48 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 861716

People

(Reporter: j.smits.work, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160728203720

Steps to reproduce:

1. Created multiple calls using webrtc (lets say 2)
2. Permissions dialog showed up
3. I pressed arrow down icon next to "Share Selected Devices"
4. I selected "Always Share" 


Actual results:

Only one of two calls actually started properly. Second Call just stacked on state when permissions needs to be accepted.

IMPORTANT NOTE: If we disconnect both calls and then start them again - everything works very nice. Problem is when we use "Always Share" option at the very first time.


Expected results:

Both Calls should start together because we allowed microphone permissions for specific page permanently.
Component: Untriaged → Device Permissions
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 861716
You need to log in before you can comment on or make changes to this bug.