Download Panel color doesn't change if you download malicious or uncommon files

RESOLVED INVALID

Status

()

Firefox
Downloads Panel
RESOLVED INVALID
9 months ago
8 months ago

People

(Reporter: Ovidiu, Unassigned)

Tracking

(Blocks: 1 bug)

51 Branch
Points:
---

Firefox Tracking Flags

(firefox51 affected)

Details

(Whiteboard: [CHE-MVP][CHE-BUG])

[Affected versions]:

FF Nightly 51.0a1


[Affected platforms]:


Tested on Mac OS X 10.10, Windows 10 x64


[Steps to reproduce]:

1. Open Firefox and go to http://testsafebrowsing.appspot.com/
2. From "Desktop Download Warnings" choose NO.6 link "Should show an "uncommon" warning, for https .exe" and download it.  (Download Panel has a yellow dot)
3. o to http://testsafebrowsing.appspot.com/ and from "Desktop Download Warnings" choose NO.3 link "Should show a "malicious" warning, based on content with https" and download it. (Download Panel has a red dot)
4.Go to http://testsafebrowsing.appspot.com/ and from "Desktop Download Warnings" choose NO.5 link "Should show an "uncommon" warning, for .exe" and download it.

[Expected result]:
The dot color from Download Panel is yellow.

[Actual result]:
The dot color from Download Panel is red. 

Note: The color is changed from yellow to red but is not changed vice versa.
Hi Brindusa,

(In reply to ovidiu boca[:Ovidiu][PTO from: 9/19, until: 9/30] for urgent issues please contact Brindusa 
Tot from comment #0)
> [Expected result]:
> The dot color from Download Panel is yellow.
Does the dot mean a red/yellow dot at Toolbar? Could you confirm this? Thanks.

> 
> [Actual result]:
> The dot color from Download Panel is red. 
> 
> Note: The color is changed from yellow to red but is not changed vice versa.
Flags: needinfo?(brindusa.tot)
Sounds like you are fetching suspicious and severe downloads in a sequence of suspicious, severe, suspicious and are expecting the last one to win. However the code was written with the intent to display the most important warning to the user, which in this case would be the severe one.

Since the colored dot only lasts until the user opens the downloads panel we want to make sure they will be notified about the most important issue since their last inspection. This is consistent with what would happen if you had a sequence like: normal, suspicious, normal. Even though the last download was a safe one, we would still want the warning dot displayed until the user interacts with the panel.
Thanks a lot Panos for the clarification. Based on comment 2, this is the behaviour to be expected and the colour for the most severe download will be always displayed until the panel is inspected or a more severe download is done. We will update the existent test cases based on this information.

Also, based on comment 2, marking this issue as invalid.
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Flags: needinfo?(brindusa.tot)
Resolution: --- → INVALID
Whiteboard: [CHE-MVP][CHE-BUG]
You need to log in before you can comment on or make changes to this bug.