Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Add Amazon root certificates to NSS

RESOLVED FIXED

Status

NSS
CA Certificates Code
--
enhancement
RESOLVED FIXED
10 months ago
6 months ago

People

(Reporter: Kathleen Wilson, Unassigned)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: In NSS 3.28.1, Firefox 51 )

Attachments

(4 attachments)

1.18 KB, application/x-x509-ca-cert
Details
1.87 KB, application/x-x509-ca-cert
Details
668 bytes, application/x-x509-ca-cert
Details
750 bytes, application/x-x509-ca-cert
Details
(Reporter)

Description

10 months ago
Created attachment 8792032 [details]
AmazonRootCA1.cert

This bug requests inclusion in the NSS root store of the following root certificates owned by Amazon Trust Services (Amazon).
	 
Friendly Name: Amazon Root CA 1
Cert Location: https://www.amazontrust.com/repository/AmazonRootCA1.cer
SHA-1 Fingerprint: 8D:A7:F9:65:EC:5E:FC:37:91:0F:1C:6E:59:FD:C1:CC:6A:6E:DE:16
SHA-256 Fingerprint: 8E:CD:E6:88:4F:3D:87:B1:12:5B:A3:1A:C3:FC:B1:3D:70:16:DE:7F:57:CC:90:4F:E1:CB:97:C6:AE:98:19:6E
Trust Flags: Email; Websites
Test URL: https://good.sca1a.amazontrust.com/
 
Friendly Name: Amazon Root CA 3
Cert Location: http://www.amazontrust.com/repository/AmazonRootCA3.cer
SHA-1 Fingerprint: 0D:44:DD:8C:3C:8C:1A:1A:58:75:64:81:E9:0F:2E:2A:FF:B3:D2:6E
SHA-256 Fingerprint: 18:CE:6C:FE:7B:F1:4E:60:B2:E3:47:B8:DF:E8:68:CB:31:D0:2E:BB:3A:DA:27:15:69:F5:03:43:B4:6D:B3:A4
Trust Flags: Email; Websites
Test URL: https://good.sca3a.amazontrust.com/
 
Friendly Name: Amazon Root CA 2
Cert Location: http://www.amazontrust.com/repository/AmazonRootCA2.cer
SHA-1 Fingerprint: 5A:8C:EF:45:D7:A6:98:59:76:7A:8C:8B:44:96:B5:78:CF:47:4B:1A
SHA-256 Fingerprint: 1B:A5:B2:AA:8C:65:40:1A:82:96:01:18:F8:0B:EC:4F:62:30:4D:83:CE:C4:71:3A:19:C3:9C:01:1E:A4:6D:B4
Trust Flags: Email; Websites
Test URL: https://good.sca2a.amazontrust.com/
 
Friendly Name: Amazon Root CA 4
Cert Location: http://www.amazontrust.com/repository/AmazonRootCA4.cer
SHA-1 Fingerprint: F6:10:84:07:D6:F8:BB:67:98:0C:C2:E2:44:C2:EB:AE:1C:EF:63:BE
SHA-256 Fingerprint: E3:5D:28:41:9E:D0:20:25:CF:A6:90:38:CD:62:39:62:45:8D:A5:C6:95:FB:DE:A3:C2:2B:0B:FB:25:89:70:92
Trust Flags: Email; Websites
Test URL: https://good.sca4a.amazontrust.com/

This CA has been assessed in accordance with the Mozilla project guidelines, and the certificates approved for inclusion in bug #1172401. 

The next steps are as follows:
1) A representative of the CA must confirm that all the data in this bug is correct, and that the correct certificates have been attached.
2) A Mozilla representative creates a patch with the new certificates, and provides a special test version of Firefox.
3) A representative of the CA uses the test version of Firefox to confirm (by adding a comment in this bug) that the certificates have been correctly imported and that websites work correctly.
4) The Mozilla representative requests that another Mozilla representative review the patch.
5) The Mozilla representative adds (commits) the patch to NSS, then closes this bug as RESOLVED FIXED.
6) At some time after that, various Mozilla products will move to using a version of NSS which contains the certificates. This process is mostly under the control of the release drivers for those products.
(Reporter)

Comment 1

10 months ago
Created attachment 8792033 [details]
AmazonRootCA2.cert
(Reporter)

Comment 2

10 months ago
Created attachment 8792034 [details]
AmazonRootCA3.cert
(Reporter)

Comment 3

10 months ago
Created attachment 8792035 [details]
AmazonRootCA4.cert
(Reporter)

Comment 4

10 months ago
Peter, Please see step #1 above.
(Reporter)

Updated

10 months ago
Blocks: 1303383

Comment 5

10 months ago
All four attachments confirmed correct and all hashes of DER-encoded certificates (i.e. fingerprints) confirmed correct.
(Reporter)

Comment 6

10 months ago
Thanks for confirming that the data in this bug is correct.

Root inclusions are usually grouped and done as a batch when there is either a large enough set of changes or about every 3 months.

At some point in the next 3 months a test build will be provided and this bug will be updated to request that you test it. Since you are cc'd on this bug, you will get notification via email when that happens.

Updated

8 months ago
Depends on: 1296697
(Reporter)

Comment 7

7 months ago
(In reply to Kathleen Wilson from comment #0)
> 3) A representative of the CA uses the test version of Firefox to confirm
> (by adding a comment in this bug) that the certificates have been correctly
> imported and that websites work correctly.


The test build for this change is here:
https://archive.mozilla.org/pub/firefox/try-builds/kaie@kuix.de-0ff968e3d09e43aa1186a83d9df1b0159adf61e0/

Peter, please test as described here:
https://wiki.mozilla.org/CA:How_to_apply#Testing_Inclusion

Comment 8

7 months ago
All four roots pass testing.  Looks good to me.

Comment 9

7 months ago
What's going to happen next?
(Reporter)

Updated

6 months ago
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → FIXED
Whiteboard: In NSS 3.28.1, Firefox 51
You need to log in before you can comment on or make changes to this bug.