Mozilla does not load PUBLIC ENTITIES

VERIFIED DUPLICATE of bug 69799

Status

()

Core
XML
VERIFIED DUPLICATE of bug 69799
17 years ago
14 years ago

People

(Reporter: Allan Engelhardt, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
When using a PUBLIC DOCTYPE document with internal subset declarations of
entities that is referencing an external entity definition (using the % syntax),
the external entities are not loaded.

This should be valid XHTML, as far as I can tell, but Mozilla 0.9.9 barfs.  Note
that changing the reference to a SYSTEM resource does not help.

---[begin test0.xhtml]---
<?xml version="1.0" encoding="ISO-8859-1"?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.1//EN"
"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd" [
<!ENTITY % HTMLlat1 PUBLIC 
   "-//W3C//ENTITIES Latin 1 for XHTML//EN"
   "http://www.w3.org/TR/xhtml1/DTD/xhtml-lat1.ent">
%HTMLlat1;
	]>

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" >
<head>
<meta http-equiv="Content-Type" content='application/xhtml+xml;
charset=ISO-8859-1' />
</head>
<body>
<p>Test paragraph: &oslash; &aelig; ends. </p>
</body>
</html>
---[end   test0.xhtml]---
(Reporter)

Comment 1

17 years ago
Created attachment 73717 [details]
The test case shown in the original submission.
(Reporter)

Comment 2

17 years ago
See also Bux #130343
Hardware: Other → PC
Mozilla uses a non-validating parser, which is not required to read external
entities. And we don't, except in specific circumstances when the entity is in
the local file system.

The workaround here is to move the entity definitions into the internal subset.



*** This bug has been marked as a duplicate of 69799 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Hardware: PC → Other
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: petersen → rakeshmishra
v.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.