The default bug view has changed. See this FAQ.

[FlyWeb] publishServer() broken on Fennec

RESOLVED FIXED in Firefox 52

Status

()

Core
DOM: Flyweb
RESOLVED FIXED
6 months ago
4 months ago

People

(Reporter: justindarc, Unassigned, NeedInfo)

Tracking

(Blocks: 1 bug)

unspecified
mozilla52
Points:
---

Firefox Tracking Flags

(firefox52- fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 months ago
Visiting https://flyweb.github.io/ calls `navigator.publishServer()` and does not bring up the permissions prompt on Fennec Nightly. The following error is logged to the GeckoConsole:

  [JavaScript Error: "[Exception... "Failure"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: <unknown filename> :: <TOP_LEVEL> :: line 0"  data: no]"] 

Additionally, in DEBUG builds, the browser crashes with the following:

  Assertion failure: removed, at /Users/Justin/Development/Mozilla/mozilla-central/dom/flyweb/FlyWebService.cpp:1109

NOTE: This does not affect the ability to do FlyWeb discovery or connect to FlyWeb services on Fennec. This is only an issue with starting FlyWeb services from web pages using `navigator.publishServer()`.
(Reporter)

Updated

6 months ago
Blocks: 1228662
Flags: needinfo?(kvijayan)
Is this intermittent or does it always happen?
Flags: needinfo?(kvijayan)
Looked into this.  This is being caused by the addon-check failing on fennec.  Looking into how to fix (simple fix is to remove the addon check, but I doubt ehsan will be happy with that).
Created attachment 8792915 [details] [diff] [review]
fix-fennec-flyweb-addon-check.patch

The "flyweb addon check" in the content-permission check fails on Android because the path it looks for isn't present in the fennec add-on.  This change just refactors the addon-checking code into a separate function, where we look for one of two resource paths - one of which succeeds on desktop and the other on fennec.
Attachment #8792915 - Flags: review?(ehsan)

Updated

6 months ago
Attachment #8792915 - Flags: review?(ehsan) → review+

Comment 4

6 months ago
Pushed by kvijayan@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/acdba157c88f
Change FlyWeb addon check to use paths from both desktop and android resources. r=ehsan

Comment 5

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/acdba157c88f
Status: NEW → RESOLVED
Last Resolved: 6 months ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
(Assignee)

Updated

4 months ago
Product: Toolkit → Core

Comment 6

4 months ago
[Tracking Requested - why for this release]: It is very hard to fix been on it for 2 weeks and cant figure out the source of the bug I tracked the last user and it never showed me th info i need so i suggest keeping an eye on thi,s bug
tracking-firefox52: --- → ?
Flags: needinfo?(peters223480)
Tracking 52- since this is now resolved fixed.
tracking-firefox52: ? → -
You need to log in before you can comment on or make changes to this bug.