[PP] Windows 98 - Right alt key activates menus

VERIFIED DUPLICATE of bug 9333

Status

()

Core
Event Handling
P3
major
VERIFIED DUPLICATE of bug 9333
19 years ago
19 years ago

People

(Reporter: cpratt, Assigned: joki (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] Right alt key (=AltGr) should be a character modifier, not a synonyme for left alt)

(Reporter)

Description

19 years ago
Build ID: 1999090208
Platform: Windows 98 with US-International keyboard layout

To reproduce:
- Launch apprunner
- Click in a text input control on a page with a form (for example)
- Press RightAlt-S

Result: The Search menu is dropped down. (This is what you would expect if you
pressed LeftAlt-S.)

Expected result: The 'ß' character should be generated and displayed.

Similarly, pressing the right Alt key alone changes the appearance of the File
menu to indicate that the accelerator keys has been activated. This should only
happen when using the left Alt key. Compare this with Communicator 4.x's
behavior, which is correct.
(Assignee)

Comment 1

19 years ago
Tague, we don't do anything special with this.  Shouldn't the right alt cause
the character conversion before it gets sent down the pipe?

Updated

19 years ago
Whiteboard: [TESTCASE] Right alt key (=AltGr) should be a character modifier, not a synonyme for left alt

Comment 2

19 years ago
Verified the bug report as valid & definitive.

Moreover, the problem is there on Apprunner 1999092508 / WinNT4 SP5, too.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 3

19 years ago
*** This bug has been marked as a duplicate of 9333 ***
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

19 years ago
There are also other bugs that deal with the AltGR key in apprunner/seamonkey;
see also bug 13016 and bug 6036.

Marking this one as verified duplicate.
You need to log in before you can comment on or make changes to this bug.