SVG element in which there is '<a xlink:href="#">' can not be focused by TAB key

RESOLVED DUPLICATE of bug 1302341

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 1302341
2 years ago
a year ago

People

(Reporter: xdymzhang, Assigned: daoshengmu)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8792419 [details]
test.html

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/601.7.7 (KHTML, like Gecko) Version/9.1.2 Safari/601.7.7

Steps to reproduce:

I created a test.html in which there is a SVG, and under the SVG there are some <a> tags.


Actual results:

The <a> element can not be focused by TAB key, even if "tabindex" is added.


Expected results:

All the circles in the <a> element can be focused by TAB key
Component: Untriaged → SVG
Product: Firefox → Core
Version: 51 Branch → Trunk
Daosheng, can you look at this one?
Flags: needinfo?(dmu)
(Assignee)

Comment 2

2 years ago
(In reply to Cameron McCormack (:heycam) from comment #1)
> Daosheng, can you look at this one?

Sure. I will take a look at on this bug this week. Btw, it is the same to Bug 1302341.
Flags: needinfo?(dmu)
(Reporter)

Comment 3

2 years ago
Hi there, I noticed that Nightly build on Windows can work well now, but not on Mac, FYI.
(Assignee)

Updated

2 years ago
Assignee: nobody → dmu
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

2 years ago
I notice it can be fixed by removing our old override function in SVGAElement (https://dxr.mozilla.org/mozilla-central/rev/c55bcb7c777ea09431b4d16903ed079ae5632648/dom/svg/SVGAElement.cpp#193). We should just use nsSVGElement::IsFocusableInternal().

Another thing we need to follow up is why text's bounding box in SVG link element is wrong. I will keep investigating it in Bug 1302341. The good news is it is very close to be resolved.
(Reporter)

Comment 5

2 years ago
Hi Daosheng,
Is this bug fixed already?
Regards,
xdymzhang

(In reply to Daosheng Mu[:daoshengmu] from comment #4)
> I notice it can be fixed by removing our old override function in
> SVGAElement
> (https://dxr.mozilla.org/mozilla-central/rev/
> c55bcb7c777ea09431b4d16903ed079ae5632648/dom/svg/SVGAElement.cpp#193). We
> should just use nsSVGElement::IsFocusableInternal().
> 
> Another thing we need to follow up is why text's bounding box in SVG link
> element is wrong. I will keep investigating it in Bug 1302341. The good news
> is it is very close to be resolved.
(Assignee)

Updated

2 years ago
See Also: → bug 1302341
(Assignee)

Comment 6

2 years ago
Hi xdymzhang,

There is a workable patch at bug 1302341. Currently, it is under the review process. Hope it would be soon.
(Assignee)

Comment 7

a year ago
Because Bug 1302341 has landed, we can make it as resolved.
(Assignee)

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1302341
You need to log in before you can comment on or make changes to this bug.