At some point, audio tags start having problems decoding

RESOLVED DUPLICATE of bug 1247056

Status

()

Core
Audio/Video: Playback
RESOLVED DUPLICATE of bug 1247056
2 years ago
2 years ago

People

(Reporter: Bodo Thiesen, Unassigned)

Tracking

48 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Currently, I'm developing some JavaScript, that randomly plays short (<2seconds) sound files (one each time out of over a hundred). When I started, everything worked fine, one 4 minute background music played and all those short sounds. However, upon one reloading to test the new JavaScript, instead of hearing background music, I got

Media resource [...].mp3 could not be decoded.

To be highly clear: It's the same, that played fine seconds ago. Now, reloading again solved it for the background music, now the other sound files don't play any longer. When I pause the music, sounds start playing again and while they are playing, I can't restart background music. There is no JavaScript involved in this problem, as the background music is just a static audio tag in the xhtml file and no piece of JavaScript ever touches that tag.

Comment 1

2 years ago
Can you provide a link to a testcase?

Other relevant questions:
- are you using a distro build or the mozilla.org version of Firefox
- does the same problem happen on a clean Firefox profile ( https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles )
- can you provide the contents of about:support
- are the mp3 files served over http:// or file:// or something else?
- does this happen with all mp3 files or just some?
Component: General → Audio/Video: Playback
Flags: needinfo?(bothie)
Product: Firefox → Core
(Reporter)

Comment 2

2 years ago
- are you using a distro build or the mozilla.org version of Firefox

Gentoo build

- does the same problem happen on a clean Firefox profile (https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles)

I'll test tomorrow and report back. However, the problem is not deterministically reproducible.

- can you provide the contents of about:support

Yes (attachement)

- are the mp3 files served over http:// or file:// or something else?

file://

- does this happen with all mp3 files or just some?

It happens with those I use in my project. Within there, it seams to affect all mp3 equally.
(Reporter)

Comment 3

2 years ago
Created attachment 8793072 [details]
about:support
(Reporter)

Comment 4

2 years ago
lol. Just created a new user to get a really fresh firefox, and what happens? SIGSEGV ...
https://bugzilla.mozilla.org/show_bug.cgi?id=1304355
Flags: needinfo?(bothie)
Can you provide a link to follow to reproduce the problem?

Do you have pulse audio installed?
Flags: needinfo?(bothie)
(Reporter)

Comment 6

2 years ago
pulse audio is not installed, support for pulse audio is turned off in my build.

To reproduce, take any list of mp3/ogg/flac/whatever-you-like and run a simple javascript, that plays them randomly in an endless loop. There is nothing special about what I do, that could possibly cause the problem. Use short ones, then you can play many in short time. I used something like this (in mean time I continued developing, but the problem was there from the beginning):

var files = [
   "1000.mp3",
   "1001.mp3",
   [...]
];

setInterval(function(){
   var path = Math.floor(Math.random() * files.length);
   var audio = new Audio(path);
   audio.play();
}, 1000);

After starting the browser, the code works until it stops working with the named error message.

BTW: "Media resource [...] could not be decoded." is a very bad error message, maybe you want to fix that first, possibly the bug becomes obvious, once we can see a useful error message.
Flags: needinfo?(bothie)
(Reporter)

Comment 7

2 years ago
Concrete steps to reproduce:

Create a sound file like this:

dd if=/dev/zero bs=11025 count=1 | sox -t raw -b 8 -c 1 -e signed-integer -r 22050 - silence.wav

then visit this xhtml:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
    <head>
     <script charset="UTF-8" lang="lang/javascript">
window.onload=function () {
    setInterval(function(){
     new Audio("silence.wav").play();
    }, 100);
};
     </script>
    </head>
    <body>
    </body>
</html>

The file should load successfully at start, but after some time (minutes), suddenly the console starts spitting out "Media resource [...]/silence.wav could not be decoded."

At that point, reloading the page won't fix it anymore. At some point, Firefox may start playing sound files again, but that behavior seems to be inconsistent.
(In reply to Bodo Thiesen from comment #6)
> pulse audio is not installed, support for pulse audio is turned off in my
> build.

Try enabling Pulse Audio.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1247056
You need to log in before you can comment on or make changes to this bug.