Firefox 49 undefined symbol: gtk_widget_path_append_for_widget On Startup on OpenSuse 11.4 / GTK version < 3.2

RESOLVED WONTFIX

Status

()

P5
critical
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: drichard, Unassigned)

Tracking

({crash})

49 Branch
Unspecified
Linux
crash
Points:
---

Firefox Tracking Flags

(firefox49- wontfix, firefox51 wontfix, firefox52- wontfix)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160726073904

Steps to reproduce:

We have hundreds of users on Firefox using OpenSuse 11.4.  We using version 48 and it's very stable.  I attempted to upgrade to 49, and it's crashing.  It seems like it's possibly expecting a newer version of GTK 3, which is not a possible upgraded for us at this time.   Is it possible to have a fallback mode of some type when this symbol does not exist?  No workarounds possible.


Actual results:

./firefox: symbol lookup error: /u/firefox_2016_09_20/firefox/libxul.so: undefined symbol: gtk_widget_path_append_for_widget



Expected results:

It should have started.

Comment 1

2 years ago
Also happening on a Debian 8 installation. 48.0.2 is fine, but 49.0 just crashes outright and displays the Crash Reporter right away. Trying to start in safe mode or with a different profile also leads to a crash.

Comment 2

2 years ago
[Tracking Requested - why for this release]:

Reporters, do you have some crash reports in about:crashes?
Can you provide a stacktrace?
https://developer.mozilla.org/en-US/docs/Mozilla/How_to_get_a_stacktrace_for_a_bug_report
Severity: normal → critical
status-firefox49: --- → affected
tracking-firefox49: --- → ?
Flags: needinfo?(drichard)
Keywords: crash
OS: Unspecified → Linux

Updated

2 years ago
Component: Untriaged → Widget: Gtk
Product: Firefox → Core

Updated

2 years ago
Summary: Firefox Crash On Startup on OpenSuse 11.4 → Firefox 49 Crashes On Startup on OpenSuse 11.4
(Reporter)

Comment 4

2 years ago
I am not getting any Crash reports, it seems to be crashing in a manner that disallows it from creating them.  I only see:

./firefox: symbol lookup error: /u/firefox_2016_09_20/firefox/libxul.so: undefined symbol: gtk_widget_path_append_for_widget

on the command line.


desktopnxcloud:~ # rpm -qa | grep gtk-3
libgtk-3-0-3.0.0-3.3.x86_64

Some discussion on gtk_widget_path_append_for_widget in 

https://bugzilla.mozilla.org/show_bug.cgi?id=1277818

Comment 5

2 years ago
I upgraded libgtk-3-0 from 3.14 to 3.21 (temporarily, since it breaks my system in some places), and can confirm that Firefox 49 then starts and works correctly. That seems to confirm the original reporter's suspicion: Firefox 49 expects an higher version of GTK3.
(Reporter)

Comment 6

2 years ago
No upgrade path for us to install newer GTK3 on our servers as well.  Many things would break if this attempt was made.
Karl, do you have any suggestions here?
Flags: needinfo?(karlt)
I'd suggest using Firefox ESR 45 if upgrading to a supported libgtk is not an option.  Automatic updates from 45 were designed to be blocked so that this didn't happen, but there was a short period where this was not in place.

I'm surprised that 48 was working so well with GTK 3.0, as there were other reasons (which I don't recall) why 3.4 was the minimum requirement.

The issue in comment 3 is different: SEGV under gtk_style_context_get_color or g_object_unref from nsLookAndFeel::Init().  I don't know what that is, but the first thing I'd do is upgrade libgtk to 3.14.15 to see whether there is already a fix on the 3.14 branch.  Installing debug symbols for glib and libgtk and using gdb for a backtrace would provide more info, but please file a separate bug report.
Flags: needinfo?(karlt)
Priority: -- → P5
Summary: Firefox 49 Crashes On Startup on OpenSuse 11.4 → Firefox 49 undefined symbol: gtk_widget_path_append_for_widget On Startup on OpenSuse 11.4 / GTK version < 3.2
[Tracking Requested - why for this release]:

We have to wontfix this for 49.  Does it make sense to wontfix the entire bug or might there still be something we could do for 51/52?
status-firefox49: affected → wontfix
status-firefox52: --- → ?
tracking-firefox49: ? → -
tracking-firefox52: --- → ?
(In reply to Liz Henry (:lizzard) (needinfo? me) from comment #9)
> We have to wontfix this for 49.  Does it make sense to wontfix the entire
> bug or might there still be something we could do for 51/52?

Yes, we can't justify support for GTK 3.0.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(drichard)
Resolution: --- → WONTFIX
Adjusting flags based on Comment 10.
status-firefox51: --- → wontfix
status-firefox52: ? → wontfix
tracking-firefox52: ? → -
Changes from bug 1315668 removed use of gtk_widget_path_append_for_widget, so you may have more success with more recent versions.  I'd still recommend ESR45 though.
You need to log in before you can comment on or make changes to this bug.