Closed Bug 1304168 Opened 3 years ago Closed 3 years ago

JavaScript Error: "TypeError: aBrowser.removeListener is not a function" (SessionStore.js" line: 571)

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 52
Tracking Status
firefox49 --- unaffected
firefox50 --- fixed
firefox51 --- fixed
firefox52 --- fixed

People

(Reporter: JanH, Assigned: JanH)

References

Details

Attachments

(1 file)

Really stupid error, and this totally breaks the session store, inluding the restoring of zombified tabs.
Keywords: checkin-needed
Comment on attachment 8793040 [details]
Bug 1304168 - Use correct function name to remove event listener.

Approval Request Comment
[Feature/regressing bug #]: Bug 1301016
[User impact if declined]: Not necessarily user visible, but an uncaught exception in the session store should still best be avoided to avoid any nasty side effects.t
[Describe test coverage new/current, TreeHerder]: Existing tests should catch total breakage, but some subtle errors in session store behaviour might get through.
[Risks and why]: No - that line is already broken.
[String/UUID change made/needed]: none
Attachment #8793040 - Flags: approval-mozilla-beta?
Attachment #8793040 - Flags: approval-mozilla-aurora?
Actually I'm not sure whether the broken session store behaviour is related to this, because I cannot reproduce those side effects on a second attempt, but this needs fixing anyway.
This needs r+ in MozReview before autoland can do anything with it.
Keywords: checkin-needed
Severity: major → normal
Attachment #8793040 - Flags: review?(ahunt) → review?(s.kaspari)
Comment on attachment 8793040 [details]
Bug 1304168 - Use correct function name to remove event listener.

https://reviewboard.mozilla.org/r/79854/#review79042

Drive-by review.
Attachment #8793040 - Flags: review?(s.kaspari) → review+
Pushed by s.kaspari@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/639092fd692d
Use correct function name to remove event listener. r=sebastian
https://hg.mozilla.org/mozilla-central/rev/639092fd692d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Comment on attachment 8793040 [details]
Bug 1304168 - Use correct function name to remove event listener.

Fixes a recent regression with SessionRestore with ReaderMode on, Aurora51+, Beta50+
Attachment #8793040 - Flags: approval-mozilla-beta?
Attachment #8793040 - Flags: approval-mozilla-beta+
Attachment #8793040 - Flags: approval-mozilla-aurora?
Attachment #8793040 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
Hi,

Is the qe-verify+ flag still valid?

Thanks!
Flags: needinfo?(rkothari)
Redirect to Ioana.
Flags: needinfo?(rkothari) → needinfo?(ioana.chiorean)
This was not reproduced in the last couple of years. I think we can take it out - Jan would have followed up with it would have not been fixed. 
Thanks Mira and Ritu for the follow up!
Flags: qe-verify-
Flags: qe-verify+
Flags: needinfo?(ioana.chiorean)
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.