Form submission buttons frequently do nothing in 0.9.9

VERIFIED WORKSFORME

Status

()

--
major
VERIFIED WORKSFORME
17 years ago
17 years ago

People

(Reporter: geva, Assigned: alexsavulov)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
BuildID:    2002031104

Most form submission buttons no longer seem to work for me. Some do (e.g. the 
Google search form), but most simply do nothing. Other form buttons (e.g. "Clear 
fields") often do work.

Reproducible: Sometimes
Steps to Reproduce:
1. Go the URL above (or to most other form URLs)
2. Select sensible values and choose any of the form submission buttons


Actual Results:  Nothing. The button shows a visual 'depression' as expected, 
but the form does not submit

Expected Results:  Form submission

This is a new bug in 0.9.9 -- I did not have this problem in 0.9.8
I have made no changes to my configuration since 0.9.8 other than to install the 
new version.
wfm with win2k and a 1h old CVS build

Reporter: 
Have you installed Mozilla over an older build ?
If yes: Please deinstall/reinstall mozilla
(Assignee)

Comment 2

17 years ago
sounds bad, but i cannot reproduce. the forms on the provided URL work
correctly. i guess that this is not a frequent bug since i didn't received any
other reports on this. a thing like this would usually cause an avalanche of
duplicate bug reports. 

Reporter:

Please try to figure out if you have some unusual system wide User Interface
settings. Also try to use the profile manager and generate a new profile and
test with that profile. Is pretty possible that you have some settings that are
seldom used and our developers did not tested with those settings. Let us know
please!

Thx!
(Assignee)

Comment 3

17 years ago
bugzilla is getting slower and worster each day. there was some kind of mid-air
collision. did I removed something that I shouldn't?

Comment 4

17 years ago
I installed Solaris 0.9.9 in a new directory.

On Solaris, it seems to send a POST message, but with no parameters. I'm using
0.9.8 to submit this comment, as using 0.9.9 results in a RED box containing
"You did not select any bugs to modify."

The URL above results in an "Error Occurred While Processing Request" page. I
have also found the problem with
http://alert.sofcom.com.au/cgi-bin/EditUserDetails.cgi?brand=txu

Is this related to Bug 130301 ?
>did I removed something that I shouldn't?
No, you can verify that if you click on the "View Bug Activity" link in the bug
(Assignee)

Comment 6

17 years ago
Scott:

is the always reproductible? i cannot reproduce.
Guys, please try this in a clean profile (delete your profile and re-create).  I
can't reproduce either, that will at least tell us if that is the source of the
problem.
(Reporter)

Comment 8

17 years ago
Well, I tried it with a clean profile, and the problem is gone. Now _I'm_ unable
to recreate the problem! I've restored my settings to what they were before (at
least as far as I can remember), and everything still works. Strange. 

Comment 9

17 years ago
works for me based on the reporter's coments
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 10

17 years ago
OK. It works for me too in a new profile, but is still broken if I go back to
the old one - it looks like I'll have to recreate bookmarks, saved formfills etc :-(
Scott Davis: "http://www.mversen.de / mozilla / Copy Mail into New profile"
explains how you can try to copy all data into a new profile.

Comment 12

17 years ago
vfy
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.