cnn.com - text overflows inset table

RESOLVED FIXED in Future

Status

()

Core
Layout
P3
normal
RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: Tony Tovar, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
(I'm guessing on the "DOM Style" categorization)

It doesn't always do it but reloading seems to consistently get it to happen:
The main text of this CNN article overflows the inset table labeled "War on
Terror".  It starts at the paragraph beginning, "His first wife, Najwan Ibrahim
Ghanem, is Syrian..."
(Reporter)

Updated

16 years ago
Blocks: 118315
I see this too, but it's not DOM Style, over to Layout.
Assignee: jst → attinasi
Status: UNCONFIRMED → NEW
Component: DOM Style → Layout
Ever confirmed: true
QA Contact: ian → petersen

Comment 2

16 years ago
Changing QA contact
QA Contact: petersen → moied

Comment 3

16 years ago
This page was OK with 2002031008 NT4.

With 2002031203, the bug is there.

Karnaze's checkin ?????
I see the bug using a cvs build from today on Linux.
OS: Windows NT → All

Comment 5

16 years ago
Using build 20020322 on WINXP, the only case this happens is If a user clicks on
reload button very fast many several times, even before repainting the page this
happens. Screen dump  fallows.. 
Priority: -- → P3

Comment 6

16 years ago
Created attachment 75700 [details]
Screen dump from CNN
(Reporter)

Comment 7

16 years ago
With both 2002-03-20 and 2002-03-22 (on WinNT), this bug still occurs. 
Specifically, it displays correctly when first loaded (presumably from cache?)
but gets messed-up again if you click Reload.  From then on, pressing either
Reload or Shift-Reload results in a messed-up page about 30-50% of the time.

Comment 8

16 years ago
I was able to see the bug after several reloads, and it may be a floater 
problem. We need a test case. Moving to future, since it is unlikely to get 
serious attention for m1.0. 
Keywords: qawanted
Target Milestone: --- → Future
(Reporter)

Comment 9

16 years ago
(Still occurring periodically with build 2002-04-03(03))

Well, I wasted about an hour trying to make a test case.  The page is full of
Javascript calls so if it's related to one of them, it's over my head.

Instead, I noticed several things about the incorrect display-case:
- the position of the "War on Terror" box doesn't change
- the center column of text wraps at the point where 1 of 2 GIFs exist in the
inset box
- the HTML references to the GIFs are
<IMG SRC="spacer.gif" ALT="" WIDTH="164" HEIGHT="5" BORDER="0">
<IMG SRC="bullet.gif" ALT="" WIDTH="4" HEIGHT="4" BORDER="0" HSPACE=5 VSPACE="5">
- The spacer.gif image is 15x15 pixels

Now, since this occurs sporadically, I figure there's a timing issue going on
with Mozilla vs CNN's servers.  Is it possible that Mozilla misallocates the
size of one of the GIFs if it's not sent back quickly enough by the server?  Or,
is there a problem between the mismatched size of the spacer.gif, i.e. it's HTML
specified WIDTH vs reality?

Comment 10

16 years ago
Mandrake Linux 8.2  Mozilla 20020629

Not able to reproduce this.
Are you seeing this on current builds ? 
(Reporter)

Comment 11

16 years ago
I haven't been on the cnn.com site in awhile, but I'm still seeing overlapping
text on other sites.  Is there a tracking bug for these kinds of rendering
errors, i.e., where other sites are reported?  Or, should I file new bugs for
the other sites?

Sorry, at the moment, I don't know an example but I know it happened to me in
the past week. I reviewed the Mozilla History but couldn't remember which was
the problem.

Comment 12

16 years ago
Is this still an issue? I went to the above url with Moz 1.0 and I can't 
reproduce it...
(Reporter)

Comment 13

16 years ago
Seems ok to me, too.  Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.