Developer Tools: storage inspector does not show connected indexeddb for Web Extensions

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
2 years ago
7 months ago

People

(Reporter: u579981, Assigned: miker)

Tracking

48 Branch
x86_64
Windows 10

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
str
Created attachment 8793311 [details]
firefoxbug.txt

User Agent: Mozilla/5.0 (Windows NT 10.0; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

- install firedepot extension (the empty default database will suffice to reproduce the bug)
- start firedepot with its browseraction button
- open developer tools / storage inspector
- go to indexed DB


Actual results:

storage inspector does not show firedepot.db database?


Expected results:

storage inspector should show firedepot.db database.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
(Reporter)

Updated

2 years ago
Summary: developertools/storage inspector does not show connected indexeddb → Developer Tools: storage inspector does not show connected indexeddb
(Reporter)

Updated

2 years ago
Component: Untriaged → Developer Tools: Inspector
(Reporter)

Updated

2 years ago
Component: Developer Tools: Inspector → Developer Tools: Storage Inspector
firedepot can be downloaded from https://addons.mozilla.org/en-US/firefox/addon/firedepot/

The storage inspector cannot access the indexedDB because this is a web extension. Web extensions have a special status when it comes to accessing their resources.

Updating bug title as appropriate.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Summary: Developer Tools: storage inspector does not show connected indexeddb → Developer Tools: storage inspector does not show connected indexeddb for Web Extensions
This was fixed by bug 1276339
Assignee: nobody → mratcliffe
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
No longer blocks: 1312444

Updated

7 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.