Intermittent /2dcontext/building-paths/canvas_complexshapes_beziercurveto_001.htm | No data received over socket

RESOLVED WORKSFORME

Status

()

Core
Graphics
P3
normal
RESOLVED WORKSFORME
a year ago
5 months ago

People

(Reporter: Treeherder Bug Filer, Assigned: rhunt)

Tracking

({intermittent-failure, regression})

51 Branch
intermittent-failure, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

(Reporter)

Description

a year ago
treeherder
Filed by: tomcat [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=3864215&repo=autoland

https://queue.taskcluster.net/v1/task/C-9_Ll4DR4y6xIUWQd7hRw/runs/0/artifacts/public%2Flogs%2Flive_backing.log
ryan, seems a regression of bug 1289251
Blocks: 1289251
Flags: needinfo?(ryanhunt)
(Assignee)

Comment 2

a year ago
From the log it looks like there's something wrong with the window causing XGetWindowAttributes to fail. It does this first in CompositorOGL [1], and then I'm guessing it happens in X11CompositorWidget too [2]. Without the window attributes we wouldn't have a visual which would give us a bad format which causes all the X11WindowSurface creation to fail [3][4].

It looks like there should be better error handling in X11CompositorWidget to make it clear that XGetWindowAttributes failed. Something is going wrong in the initialization of the window/display in X11CompositorWidget, but I'm not sure if that is from a regression from bug 1289251 or is unrelated. When there is no gpu-process X11CompositorWidget should not be doing anything new with x11 windows/displays than what was already done before.


[1] http://searchfox.org/mozilla-central/source/gfx/gl/GLContextProviderGLX.cpp#1253
[2] http://searchfox.org/mozilla-central/source/widget/gtk/X11CompositorWidget.cpp#32
[3] http://searchfox.org/mozilla-central/source/widget/nsShmImage.cpp#186
[4] http://searchfox.org/mozilla-central/source/widget/gtk/WindowSurfaceX11.cpp#26
Flags: needinfo?(ryanhunt)
Assignee: nobody → ryanhunt
Keywords: regression
Priority: -- → P3
Whiteboard: [gfx-noted]

Comment 3

a year ago
25 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* autoland: 14
* try: 5
* mozilla-inbound: 4
* mozilla-central: 1
* fx-team: 1

Platform breakdown:
* linux64: 24
* osx-10-10: 1

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1304659&startday=2016-10-24&endday=2016-10-30&tree=all
Went away around October 28.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
Version: unspecified → 51 Branch

Comment 5

5 months ago
9 failures in 864 pushes (0.01 failures/push) were associated with this bug in the last 7 days.   

Repository breakdown:
* try: 6
* mozilla-central: 3

Platform breakdown:
* windows10-64-vm: 9

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1304659&startday=2017-06-05&endday=2017-06-11&tree=all
You need to log in before you can comment on or make changes to this bug.