Closed Bug 1304757 Opened 4 years ago Closed 3 years ago

[ur] Search engine setup for Firefox for Urdu

Categories

(Firefox :: Search, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: flod, Assigned: flod)

References

()

Details

(Keywords: productization)

Attachments

(1 file)

We want to ship Firefox with a good list of search engines for Urdu. 

We'll do this in three phases: First, the localization team and flod (Francesco Lodolo) will look at the market for the language and come up with a good set of search providers. Mohammad, we'll need your input on this. The guidelines for making recommendations are found on <https://wiki.mozilla.org/L10n:Firefox/Productization>. 

We currently use this set for en-US, to which we can fall back in the case of lacking localized alternatives:
Google, Yahoo!, Bing, Amazon, Twitter, Wikipedia

After we decided on a particular search engine, flod will contact the owner and ask for permission and for specifics, like proper search flags. Mohammad, we'll likely need your help to at least get the owner's contact information.

Once we have a specification on what the search engines for Urdu should look like, flod and the localization team will work on an implementation on that. flod will create and attach patches for the desired changes and get them reviewed. After a successful review, flod will land them. Mohammad, if you're interested, you could create the patches, too. You'd ask flod for review on those before landing.

Please don't commit any modifications in browser/searchplugins to the hg repository without a patch reviewed by flod, Stas, Axel or someone else appointed by flod. The data here is sensitive to users and our search partners, thus requiring extra care here.

The Urdu team and flod will be driving this bug to completion.
Assignee: nobody → francesco.lodolo
Hi Flod,
my suggestion would be to go with 

>Google, Yahoo(both mobile version), Bing, Duck Duck Go, Amazon, Wikipedia, Twitter

For amazon amazon.in will work and kindly use ur.wikipedia.org
Mohammed, I completely forgot: can you provide in this bug the translation in Urdu of 'Wikipedia, the Free Encyclopedia'?

It should be available under the logo here too
https://ur.wikipedia.org/wiki/خاص:تلاش
Flags: needinfo?(myaseen.khan)
@mike
Can you give me a pointer for parameters in Amazon? Looks like we don't have any amazon.in
My guess would be to use tag=firefox-in-21, based on other languages.

When ready I'll need to ask you to review the patch, given the brand new workflow.
Flags: needinfo?(mozilla)
Looking at list.json, we don't use an India specific Amazon.

I don't know why that is. I'll see what I can find out.
Flags: needinfo?(mozilla)
Hi Flod thanks for asking, here you go "ویکیپیڈیا آزاد دائرۃ المعارف"

Regarding amazon.in query my hunch is that we have used it previously while setting plugins for fennec.
See this bug https://bugzilla.mozilla.org/show_bug.cgi?id=1224261 I hope that's not the different thing.
Flags: needinfo?(myaseen.khan)
Thanks for the translation.

Good point about Amazon, it's used in Fennec but it has a parameter set to 'mozilla-20', like en-US and other locales.
But it looks like on desktop they follow a different pattern. Let's see if Mike can find anything out.
From Joanne:

Use local Amazon, don't worry about codes.
(In reply to Mike Kaply [:mkaply] from comment #7)
> Use local Amazon, don't worry about codes.
Does it mean that I can make up a code (using 'in' instead of another region), just to have a consistent structure?
> Does it mean that I can make up a code (using 'in' instead of another region), just to have a consistent structure?

No, just leave out the tag line completely.
Comment on attachment 8819889 [details]
Bug 1304757 - [ur] Search engine setup for Firefox,

https://reviewboard.mozilla.org/r/99526/#review102262
Attachment #8819889 - Flags: review?(mozilla) → review+
Keywords: checkin-needed
Pushed by ihsiao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d960f26e4466
[ur] Search engine setup for Firefox, r=mkaply
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/d960f26e4466
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Moving to Firefox::Search to be able to ask for approval-aurora
Component: ur / Urdu → Search
Product: Mozilla Localizations → Firefox
Target Milestone: mozilla53 → ---
Comment on attachment 8819889 [details]
Bug 1304757 - [ur] Search engine setup for Firefox,

Approval Request Comment
[Feature/Bug causing the regression]: - 
[User impact if declined]: Unable to properly test Urdu Developer Edition builds.
[Is this code covered by automated tests?]: -
[Has the fix been verified in Nightly?]: No, builds are available on the aurora channel.
[Needs manual test from QE? If yes, steps to reproduce]: No
[List of other uplifts needed for the feature/fix]: None
[Is the change risky?]: No
[Why is the change risky/not risky?]: It only impacts localized Urdu builds
[String changes made/needed]: None
Attachment #8819889 - Flags: approval-mozilla-aurora?
Comment on attachment 8819889 [details]
Bug 1304757 - [ur] Search engine setup for Firefox,

search localization for urdu, aurora52+
Attachment #8819889 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.