bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Send unexpected processor errors to Sentry with raven

RESOLVED DUPLICATE of bug 1231783

Status

Socorro
Webapp
RESOLVED DUPLICATE of bug 1231783
2 years ago
a year ago

People

(Reporter: peterbe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
If any out of the ordinary python exceptions happen inside the processors we should send them to Sentry.
(Reporter)

Comment 1

2 years ago
We might be able to do this in the PolyCrashStorage class in particular. What do you think Adrian?
Flags: needinfo?(adrian)
I believe that should be done in the processor_app, or wherever we catch all exceptions in that stack.
Flags: needinfo?(adrian)
(Reporter)

Updated

2 years ago
Summary: Send unexpected errors to Sentry with raven → Send unexpected processor errors to Sentry with raven

Comment 3

2 years ago
These errors were swallowed in part because of the noise they would generate. We should pay close attention to the increased load on sentry from stage when this lands.
This seems like a duplicate of bug #1231783. Does that seem right? I can't tell for sure because the Component is marked "webapp", but I suspect that's just a mistake.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1231783
You need to log in before you can comment on or make changes to this bug.